aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:00:15 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit5866de26d902c5b98b73ed80b37b80e60816de56 (patch)
treee73375fe94cbf170a92c6b1104f891ae9d569af3
parent47779dc5b5a2bdf3c72f443e4515b75671dbad94 (diff)
downloadguix-5866de26d902c5b98b73ed80b37b80e60816de56.tar
guix-5866de26d902c5b98b73ed80b37b80e60816de56.tar.gz
gnu: Add ruby-sass.
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 77005a29c9..fd79417ee0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7099,3 +7099,37 @@ https://github.com/flavorjones/loofah-activerecord).")
(home-page
"http://i.loveruby.net/en/projects/racc/")
(license license:expat)))
+
+(define-public ruby-sass
+ (package
+ (name "ruby-sass")
+ (version "3.4.22")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "sass" version))
+ (sha256
+ (base32
+ "0dkj6v26fkg1g0majqswwmhxva7cd6p3psrhdlx93qal72dssywy"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; Cannot run sass-spec options because the sass-spec package does
+ ;; not work. TODO: Fix.
+ `(#:test-target "test:ruby"))
+ (native-inputs
+ `(("ruby-rubycop" ,ruby-rubocop)
+ ("ruby-ruby-progressbar" ,ruby-ruby-progressbar)))
+ (synopsis
+ " Sass makes CSS fun again. Sass is an extension of CSS, adding
+ nested rules, variables, mixins, selector inheritance, and more.
+ It's translated to well-formatted, standard CSS using the
+ command line tool or a web-framework plugin.
+")
+ (description
+ " Sass makes CSS fun again. Sass is an extension of CSS, adding
+ nested rules, variables, mixins, selector inheritance, and more.
+ It's translated to well-formatted, standard CSS using the
+ command line tool or a web-framework plugin.
+")
+ (home-page "http://sass-lang.com/")
+ (license license:expat)))