aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:44:01 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:02 +0100
commit571814e658df70bd846f064eab94a0137f54683a (patch)
tree39802507d055316b4a668cd009f888ef3e6a91bc
parent411ceadc22a711e0eb148c4331ac68b2be68026b (diff)
downloadguix-571814e658df70bd846f064eab94a0137f54683a.tar
guix-571814e658df70bd846f064eab94a0137f54683a.tar.gz
gnu: Add ruby-rest-client.
-rw-r--r--gnu/packages/ruby.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 34236979eb..1a41af9d0d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5636,3 +5636,44 @@ percentage, bars of various formats, elapsed time and estimated time remaining.
"Easily get truthiness values of Ruby objects")
(home-page "https://rubygems.org/gems/truthy")
(license #f)))
+
+(define-public ruby-rest-client
+ (package
+ (name "ruby-rest-client")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rest-client" version))
+ (sha256
+ (base32
+ "1m8z0c4yf6w47iqz6j2p7x1ip4qnnzvhdph9d5fgx081cvjly3p7"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-dependencies
+ (lambda _
+ (substitute* "rest-client.gemspec"
+ ((".*pry.*") "\n"))
+ #t))
+ (add-before 'check 'delete-network-tests
+ (lambda _
+ (delete-file "spec/integration/request_spec.rb")
+ #t)))))
+ (propagated-inputs
+ `(("ruby-http-cookie" ,ruby-http-cookie)
+ ("ruby-mime-types" ,ruby-mime-types)
+ ("ruby-netrc" ,ruby-netrc)))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-webmock", ruby-webmock)
+ ("ruby-rspec", ruby-rspec-2)))
+ (synopsis
+ "A simple HTTP and REST client for Ruby, inspired by the Sinatra microframework style of specifying actions: get, put, post, delete.")
+ (description
+ "A simple HTTP and REST client for Ruby, inspired by the Sinatra microframework style of specifying actions: get, put, post, delete.")
+ (home-page
+ "https://github.com/rest-client/rest-client")
+ (license license:expat)))