aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-11 07:15:39 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-11 07:15:39 +0100
commit45d5c8025371c99d6e40168c240b0df67935b259 (patch)
tree6ce5d4c1037be13cc831c2ecf69ae01df0eaf5c2
parent7a9283a619ac60771abcffdca45d027ff9703c2a (diff)
downloadguix-45d5c8025371c99d6e40168c240b0df67935b259.tar
guix-45d5c8025371c99d6e40168c240b0df67935b259.tar.gz
gnu: libvisio: Update to 0.1.6.
* gnu/packages/libreoffice.scm (libvisio): Update to 0.1.6. [source](patches): Remove. * gnu/packages/patches/libvisio-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/libreoffice.scm5
-rw-r--r--gnu/packages/patches/libvisio-fix-tests.patch35
3 files changed, 2 insertions, 39 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2be4acc9b9..61bebe662f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -825,7 +825,6 @@ dist_patch_DATA = \
%D%/packages/patches/libusb-0.1-disable-tests.patch \
%D%/packages/patches/libusb-for-axoloti.patch \
%D%/packages/patches/libvirt-CVE-2017-1000256.patch \
- %D%/packages/patches/libvisio-fix-tests.patch \
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
%D%/packages/patches/libxcb-python-3.5-compat.patch \
%D%/packages/patches/libxfont-CVE-2017-13720.patch \
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index aa3fb3e549..e3e97c1a95 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -520,15 +520,14 @@ created by PageMaker version 6.x and 7.")
(define-public libvisio
(package
(name "libvisio")
- (version "0.1.5")
+ (version "0.1.6")
(source
(origin
(method url-fetch)
(uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
name "-" version ".tar.xz"))
- (patches (search-patches "libvisio-fix-tests.patch"))
(sha256 (base32
- "132szijxm95ibzq5qqaylifbf6wa81g08jxggnwv22v60dwhc2j3"))))
+ "1yahpfl13qk6178irv8jn5ppxdn7isafqisyqsdw0lqxcz9h447y"))))
(build-system gnu-build-system)
(native-inputs
`(("cppunit" ,cppunit)
diff --git a/gnu/packages/patches/libvisio-fix-tests.patch b/gnu/packages/patches/libvisio-fix-tests.patch
deleted file mode 100644
index 335f7c11a8..0000000000
--- a/gnu/packages/patches/libvisio-fix-tests.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Tests assume a CET timezone, but do not respect the "TZ" variable.
-
-This patch is a "squashed" version of these upstream commits:
-<https://cgit.freedesktop.org/libreoffice/libvisio/commit/?id=a97d30ad693374deab404ec31fe00665882cc949>
-<https://cgit.freedesktop.org/libreoffice/libvisio/commit/?id=c933df45a873e566c6ce4e5de5f829e64eb892f5>
-
-diff --git a/src/test/Makefile.am b/src/test/Makefile.am
-index 59d3419..23049b5 100644
---- a/src/test/Makefile.am
-+++ b/src/test/Makefile.am
-@@ -29,4 +29,7 @@ EXTRA_DIST = \
- data/dwg.vsdx \
- $(test_SOURCES)
-
-+# ImportTest::testVsdMetadataTitleUtf8 checks formatted date string
-+AM_TESTS_ENVIRONMENT = TZ=UTC; export TZ;
-+
- TESTS = test
-diff --git a/src/test/importtest.cpp b/src/test/importtest.cpp
-index e05b3c1..32fb185 100644
---- a/src/test/importtest.cpp
-+++ b/src/test/importtest.cpp
-@@ -242,8 +242,8 @@ void ImportTest::testVsdMetadataTitleUtf8()
- // Test the case when the string is UTF-8 encoded already in the file.
- assertXPath(m_doc, "/document/setDocumentMetaData", "title", "mytitle\xC3\xA9\xC3\xA1\xC5\x91\xC5\xB1");
- // Test <dcterms:created> and <dcterms:modified>.
-- assertXPath(m_doc, "/document/setDocumentMetaData", "creation-date", "2014-11-26T09:24:56Z");
-- assertXPath(m_doc, "/document/setDocumentMetaData", "date", "2014-11-26T09:24:56Z");
-+ assertXPath(m_doc, "/document/setDocumentMetaData", "creation-date", "2014-11-26T08:24:56Z");
-+ assertXPath(m_doc, "/document/setDocumentMetaData", "date", "2014-11-26T08:24:56Z");
- }
-
- void ImportTest::testVsdUserDefinedMetadata()
---
-2.1.4