aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:43:51 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:02 +0100
commit411ceadc22a711e0eb148c4331ac68b2be68026b (patch)
tree4d74b9f08a95477f84ba0cfcf36053583b4a99ed
parenta2f8721dd1d4491a9c5751030920be3be460e084 (diff)
downloadguix-411ceadc22a711e0eb148c4331ac68b2be68026b.tar
guix-411ceadc22a711e0eb148c4331ac68b2be68026b.tar.gz
gnu: Add ruby-truthy.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5234479117..34236979eb 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5613,3 +5613,26 @@ percentage, bars of various formats, elapsed time and estimated time remaining.
"A Ruby implementation of the Coveralls API.")
(home-page "https://coveralls.io")
(license license:expat)))
+
+(define-public ruby-truthy
+(package
+ (name "ruby-truthy")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "truthy" version))
+ (sha256
+ (base32
+ "19silgd65j3qwfk5w891p9wcmzdmi9ddm2kg5zbvvqn2h9lkfzmd"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Files required for testing are not in gem, and homepage
+ ; has disappeared.
+ (propagated-inputs `(("ruby-hoe" ,ruby-hoe)))
+ (synopsis
+ "Easily get truthiness values of Ruby objects")
+ (description
+ "Easily get truthiness values of Ruby objects")
+ (home-page "https://rubygems.org/gems/truthy")
+ (license #f)))