aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:50:51 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit2b477b3610d1765f387999b388418249fd5e17aa (patch)
tree6edbf4e986da8f7c2d290b76e5fc125e4dcf9f3b
parent1e8448247f12a44434e481d1f458c180d768ab95 (diff)
downloadguix-2b477b3610d1765f387999b388418249fd5e17aa.tar
guix-2b477b3610d1765f387999b388418249fd5e17aa.tar.gz
gnu: Add ruby-launchy.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c3ce994d35..5d88de3612 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6604,3 +6604,25 @@ minutes of work.
")
(home-page "https://github.com/JEG2/highline")
(license #f)))
+
+(define-public ruby-launchy
+ (package
+ (name "ruby-launchy")
+ (version "2.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "launchy" version))
+ (sha256
+ (base32
+ "190lfbiy1vwxhbgn4nl4dcbzxvm049jwc158r2x7kq3g5khjrxa2"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-addressable" ,ruby-addressable)))
+ (synopsis
+ "Launchy is helper class for launching cross-platform applications in a fire and forget manner. There are application concepts (browser, email client, etc) that are common across all platforms, and they may be launched differently on each platform. Launchy is here to make a common approach to launching external application from within ruby programs.")
+ (description
+ "Launchy is helper class for launching cross-platform applications in a fire and forget manner. There are application concepts (browser, email client, etc) that are common across all platforms, and they may be launched differently on each platform. Launchy is here to make a common approach to launching external application from within ruby programs.")
+ (home-page
+ "http://github.com/copiousfreetime/launchy")
+ (license #f)))