aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:57:45 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 10:50:32 +0100
commit15dc45f4649ca13dd36b41c2231b579e9a2edcad (patch)
tree9c79d1ef664a04673ba1157f7aa193252f302565
parent14f35037a5e7901b45fc50777aad7c87515651d0 (diff)
downloadguix-15dc45f4649ca13dd36b41c2231b579e9a2edcad.tar
guix-15dc45f4649ca13dd36b41c2231b579e9a2edcad.tar.gz
gnu: Add ruby-ruby-progressbar.
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 81af9e4b19..4dea344f7e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5312,3 +5312,33 @@ adds support for IRIs and URI templates.")
("ruby-thor" ,ruby-thor)))
(native-inputs
`())))
+
+;; There is a separate gem called 'progressbar', so we name the package here
+;; 'ruby-ruby-progressbar'.
+(define-public ruby-ruby-progressbar
+ (package
+ (name "ruby-ruby-progressbar")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ruby-progressbar" version))
+ (sha256
+ (base32
+ "1qzc7s7r21bd7ah06kskajc2bjzkr9y0v5q48y0xwh2l55axgplm"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests require further dependencies such as 'rspectacular'.
+ (synopsis
+ "Ruby/ProgressBar is an extremely flexible text progress bar library for Ruby.
+The output can be customized with a flexible formatting system including:
+percentage, bars of various formats, elapsed time and estimated time remaining.
+")
+ (description
+ "Ruby/ProgressBar is an extremely flexible text progress bar library for Ruby.
+The output can be customized with a flexible formatting system including:
+percentage, bars of various formats, elapsed time and estimated time remaining.
+")
+ (home-page
+ "https://github.com/jfelchner/ruby-progressbar")
+ (license license:expat)))