aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:49:24 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit13428cc674460307e484bc697d4acca8b490a3fe (patch)
tree38308cbdfa36b1798e3085681bb6149c4bd0cd30
parent0cebf80004769904f2ca6a36db527dc1120e7d03 (diff)
downloadguix-13428cc674460307e484bc697d4acca8b490a3fe.tar
guix-13428cc674460307e484bc697d4acca8b490a3fe.tar.gz
gnu: Add ruby-haml.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 930dc933d8..1842907f92 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6437,3 +6437,28 @@ to support fast builds of The Ruby Racer")
to support fast builds of The Ruby Racer")
(home-page "http://github.com/cowboyd/libv8")
(license license:expat)))
+
+;; haml 4 cannot currently be packaged because tilt is not yet packaged.
+(define-public ruby-haml
+ (package
+ (name "ruby-haml")
+ (version "4.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "haml" version))
+ (sha256
+ (base32
+ "0mrzjgkygvfii66bbylj2j93na8i89998yi01fin3whwqbvx0m1p"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; circular dependency with tilt
+; (propagated-inputs `(("ruby-tilt" ,ruby-tilt)))
+ (synopsis "Haml (HTML Abstraction Markup Language) library.")
+ (description
+ "Haml (HTML Abstraction Markup Language) is a layer on top of HTML or XML
+that is designed to express the structure of documents using indentation rather
+than closing tags. It was originally envisioned as a plugin for Ruby on Rails,
+but it can function as a stand-alone templating engine.")
+ (home-page "http://haml.info/")
+ (license license:expat)))