aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:46:53 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:02 +0100
commit09bd934163f709b7b9f10f9792775180e5cbcf5c (patch)
tree67e18b4be52906a765ff4f0cba7652607746133d
parent7f975bf3572ebf1f87c1250457f20814bc36f8ea (diff)
downloadguix-09bd934163f709b7b9f10f9792775180e5cbcf5c.tar
guix-09bd934163f709b7b9f10f9792775180e5cbcf5c.tar.gz
gnu: Add ruby-cane.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4a259172ea..50eb29204f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6097,3 +6097,24 @@ using a strict syntax definition and supporting several common extensions.
(home-page "http://github.com/yob/pdf-reader")
(license #f)))
+(define-public ruby-cane
+ (package
+ (name "ruby-cane")
+ (version "2.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "cane" version))
+ (sha256
+ (base32
+ "176x9g8ax9xky4303sf0xzf6ya62mdrm4bfrdj0hhy45x43v03x1"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-parallel" ,ruby-parallel)
+ ("bundler" ,bundler)))
+ (synopsis
+ "Fails your build if code quality thresholds are not met")
+ (description
+ "Fails your build if code quality thresholds are not met")
+ (home-page "http://github.com/square/cane")
+ (license license:asl2.0)))