aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:40:29 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 10:50:32 +0100
commit07bf8c153e23de010f5ff5a62ac09a6670a09de5 (patch)
tree87ac1a6f0c121153a82af2a3535deff5cbd7a7c5
parent2676628ffba9ef9cacbb0a15e6fd730a73e51f1f (diff)
downloadguix-07bf8c153e23de010f5ff5a62ac09a6670a09de5.tar
guix-07bf8c153e23de010f5ff5a62ac09a6670a09de5.tar.gz
gnu: Add ruby-multi-test.
* gnu/packages/check.scm (ruby-multi-test): New variable.
-rw-r--r--gnu/packages/check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 712e470fea..3d326dacec 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -63,6 +63,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (guix build-system ruby)
#:use-module (guix build-system trivial))
(define-public check
@@ -2030,3 +2031,29 @@ aspects of UnitTest++. UnitTest++ is mostly standard C++ and makes minimal use
of advanced library and language features, which means it should be easily
portable to just about any platform.")
(license license:expat)))
+
+(define-public ruby-multi-test
+ (package
+ (name "ruby-multi-test")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "multi_test" version))
+ (sha256
+ (base32
+ "1sx356q81plr67hg16jfwz9hcqvnk03bd9n75pmdw8pfxjfy1yxd"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; Tests require different sets of specific gem versions to be available,
+ ;; and there is no gemfile that specifies the newest versions of
+ ;; dependencies to be tested.
+ #:tests? #f))
+ (synopsis
+ "Interface to testing libraries loaded into a running Ruby process")
+ (description
+ "@code{multi_test} provides a uniform interface onto whatever testing
+libraries that have been loaded into a running Ruby process to help control
+rogue test/unit/autorun requires.")
+ (home-page "https://github.com/cucumber/multi_test")
+ (license license:expat)))