aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-23 11:42:15 +1000
committerChristopher Baines <mail@cbaines.net>2018-01-27 13:41:45 +0000
commitec80796b045209b0fed3029b3f41e89f49441bcd (patch)
tree61065c1285281794d3c24ed421cb5896b3e18291
parentc687d149647a2ea5469836eca3d78b31c99f5f69 (diff)
downloadguix-ec80796b045209b0fed3029b3f41e89f49441bcd.tar
guix-ec80796b045209b0fed3029b3f41e89f49441bcd.tar.gz
gnu: Add ruby-erubis.
* gnu/packages/ruby.scm (ruby-erubis): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ffadbbd2c5..135879c91e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -801,6 +801,29 @@ functions.")
(home-page "https://github.com/ahoward/options")
(license license:ruby)))
+(define-public ruby-erubis
+ (package
+ (name "ruby-erubis")
+ (version "2.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "erubis" version))
+ (sha256
+ (base32
+ "1fj827xqjs91yqsydf0zmfyw9p4l2jz5yikg3mppz6d7fi8kyrb3"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; tests do not run properly with Ruby 2.0
+ (synopsis "Implementation of embedded Ruby (eRuby)")
+ (description
+ "Erubis is a fast implementation of embedded Ruby (eRuby) with several
+features such as multi-language support, auto escaping, auto trimming spaces
+around @code{<% %>}, a changeable embedded pattern, and Ruby on Rails
+support.")
+ (home-page "http://www.kuwata-lab.com/erubis/")
+ (license license:expat)))
+
(define-public ruby-orderedhash
(package
(name "ruby-orderedhash")