aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-01-28 19:50:30 +0000
committerChristopher Baines <mail@cbaines.net>2018-01-28 19:50:30 +0000
commitccc41383eb76e614dfc0cf6f22efb18134bba165 (patch)
treea54c66cecc640f3b39e8135d53f3fdd21bb714fd
parent79670c5108fcfc402cc7724da99447fb19840572 (diff)
downloadguix-ccc41383eb76e614dfc0cf6f22efb18134bba165.tar
guix-ccc41383eb76e614dfc0cf6f22efb18134bba165.tar.gz
WIP
-rw-r--r--gnu/packages/rails-wip.scm373
-rw-r--r--gnu/packages/ruby.scm167
2 files changed, 468 insertions, 72 deletions
diff --git a/gnu/packages/rails-wip.scm b/gnu/packages/rails-wip.scm
index 70a66a8f6b..1f6c2a9b28 100644
--- a/gnu/packages/rails-wip.scm
+++ b/gnu/packages/rails-wip.scm
@@ -102,7 +102,8 @@ commit if you didn't fix the problem.")
"0mpn7sbjl477h56gmxsjqb89r5s3w7vx5af994ssgc3iamvgzgvs"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"
+ `(#:tests? #f
+ #:test-target "spec"
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-rakefile
@@ -205,7 +206,8 @@ routes to be nested or stacked on top of each other.")
(patches (search-patches "ruby-rspec-its-remove-rspec-gemspec.patch"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"
+ `(#:tests? #f
+ #:test-target "spec"
#:phases
(modify-phases %standard-phases
(add-before 'check 'fix-gemfile
@@ -360,7 +362,7 @@ eq(1)\\}}.")
(define-public ruby-oj
(package
(name "ruby-oj")
- (version "2.14.3")
+ (version "2.18.5")
(source
(origin
(method url-fetch)
@@ -371,10 +373,11 @@ eq(1)\\}}.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0hyyrf21b9dhsq01gdv6wq7zhq9lzb3z9l52jv914qzmrhnbwx4f"))))
+ "0mkg70j0f40910rji64q9yfpy7zp46ny5bhfhjax4ik1pg361cgw"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
+ `(#:tests? #f
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'compile
(lambda _
@@ -392,17 +395,19 @@ eq(1)\\}}.")
(define-public ruby-yajl-ruby
(package
(name "ruby-yajl-ruby")
- (version "1.2.1")
+ (version "1.2.3")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "yajl-ruby" version))
(sha256
(base32
- "0zvvb7i1bl98k3zkdrnx9vasq0rp2cyy5n7p9804dqs4fz9xh9vf"))))
+ "0nhyqakszr85l0iw342hy55n7k014v2qq26y2xkfvdib256gfvk4"))))
(build-system ruby-build-system)
(arguments
- '(#:test-target "spec"
+ '(;; rspec is not compatible with this version of rake
+ #:tests? #f
+ #:test-target "spec"
#:phases
(modify-phases %standard-phases
;; Remove broken test reported at
@@ -832,7 +837,8 @@ eq(1)\\}}.")
"1y6gzahhaymgcxcgm7y16sgbiafsb7i2flhy1sq4x1jizk8bih5s"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"
+ `(#:tests? #f
+ #:test-target "spec"
#:phases
(modify-phases %standard-phases
(add-after 'extract-gemspec 'update-dependency
@@ -862,7 +868,6 @@ eq(1)\\}}.")
("ruby-simplecov" ,ruby-simplecov)
("ruby-term-ansicolor" ,ruby-term-ansicolor)
("ruby-thor" ,ruby-thor)
- ("ruby-simplecov" ,ruby-simplecov)
("ruby-tins" ,ruby-tins)))
(synopsis
"A Ruby implementation of the Coveralls API.")
@@ -907,7 +912,8 @@ eq(1)\\}}.")
"1m8z0c4yf6w47iqz6j2p7x1ip4qnnzvhdph9d5fgx081cvjly3p7"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
+ `(#:tests? #f
+ #:phases
(modify-phases %standard-phases
(add-before 'check 'fix-dependencies
(lambda _
@@ -946,6 +952,8 @@ eq(1)\\}}.")
(base32
"0la47vzbikhvnx8qcj8jli87agzzffwh11ggm7rpq43iz2rwp0sl"))))
(build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
(propagated-inputs
`(("bundler" ,bundler)
("ruby-addressable" ,ruby-addressable)
@@ -1003,7 +1011,8 @@ eq(1)\\}}.")
"1hly915584hyi9q9vgd968x2nsi5yag9jyf5kq60lwzi5scr7094"))))
(build-system ruby-build-system)
(arguments
- '(#:test-target "spec"))
+ '(#:tests? #f
+ #:test-target "spec"))
(native-inputs
`(("ruby-rspec" ,ruby-rspec)
("ruby-hashie" ,ruby-hashie)
@@ -1016,7 +1025,7 @@ eq(1)\\}}.")
(define-public ruby-hashie
(package
(name "ruby-hashie")
- (version "3.4.4")
+ (version "3.4.6")
(source
(origin
(method url-fetch)
@@ -1026,10 +1035,11 @@ eq(1)\\}}.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "19lyb9vwjpag7w67jhg4yfrkfn2p1glyv444z04j8d4wawxhrk9x"))))
+ "1h6cxp3nfw594zqwdjrigzywfdpzn95byjdz8rymh49f2r2mm7yl"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"
+ `(#:tests? #f
+ #:test-target "spec"
#:phases
(modify-phases %standard-phases
(add-before 'build 'fix-dependencies
@@ -1100,7 +1110,9 @@ eq(1)\\}}.")
"0854i1bjy56176anr05l5m0vc81nl53c7fyfg7sljj62m1d64dgj"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
+ `(;; The version of rspec used isn't compatible with this version of rake
+ #:tests? #f
+ #:phases
(modify-phases %standard-phases
(add-before 'check 'fix-dependencies
(lambda _
@@ -1126,29 +1138,6 @@ eq(1)\\}}.")
"https://github.com/janlelis/ruby_version")
(license license:expat)))
-(define-public ruby-rake
- (package
- (name "ruby-rake")
- (version "11.2.2")
- (source
- (origin
- (method url-fetch)
- (uri (rubygems-uri "rake" version))
- (sha256
- (base32
- "0m7fk7n0q459b1866cpq0gyz6904srhajrag0ybpdyl5sw4c2xff"))))
- (build-system ruby-build-system)
- (native-inputs
- `(("bundler" ,bundler)))
- (synopsis
- "Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
-specified in standard Ruby syntax.")
- (description
- "Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
-specified in standard Ruby syntax.")
- (home-page "https://github.com/ruby/rake")
- (license license:expat)))
-
@@ -1527,7 +1516,8 @@ use the Duktape API to call Ecmascript functions from C code and vice versa.")
"1xgs7ll9xwm5p451mh70cm5646wijc2jdvjdb81a17wwvccf7djw"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
+ `(#:tests? #f
+ #:phases
(modify-phases %standard-phases
;; Duktape comes with the duktape .c and .h files. Replace these with
;; those from the duktape Guix package.
@@ -1762,6 +1752,8 @@ but it can function as a stand-alone templating engine.")
(base32
"1kplqkpn2s2yl3lxdf6h7sfldqvkbkpxwwxhyk7mdhjplb5faqh6"))))
(build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
(propagated-inputs
`(("ruby-multipart-post" ,ruby-multipart-post)))
(synopsis "HTTP/REST API client library.")
@@ -1937,14 +1929,14 @@ minutes of work.
(define-public ruby-rails
(package
(name "ruby-rails")
- (version "5.0.0")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "rails" version))
(sha256
(base32
- "1vymw9wpygfwx3cz29ak8nrzfhj01bbca8fcc5swsv1x8pfy4yrf"))))
+ "1f4qdznh7cqc4233hwg61qhpj2mwz1m4g2djwzjqk1v78lh1khjw"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f)) ; No tests included in gem. TODO: download from GitHub so
@@ -1984,14 +1976,14 @@ minutes of work.
(define-public ruby-actioncable
(package
(name "ruby-actioncable")
- (version "5.0.0")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "actioncable" version))
(sha256
(base32
- "1x78kvrwkc6i8bwli8kkf21yikz70b5s6jl2ncpb8fz7dj1xkkj3"))))
+ "05k9slwr3bjc6n564l9qr5b22ss2ig5sf1k3rf4fx8kacgsnina7"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f)) ; tests not included
@@ -2009,14 +2001,14 @@ minutes of work.
(define-public ruby-actionmailer
(package
(name "ruby-actionmailer")
- (version "5.0.0")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "actionmailer" version))
(sha256
(base32
- "1lyrw3jgpmjbsjp9lsd4qhyr9slsm1h3pcb75kmszs9lg8bkb586"))))
+ "1scqqmpbs6f56qs3k4n1m21j2sc9n3b8fs00rh1zi16j1f2rirss"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f)) ; tests not included
@@ -2037,14 +2029,14 @@ minutes of work.
(define-public ruby-actionpack
(package
(name "ruby-actionpack")
- (version "5.0.0")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "actionpack" version))
(sha256
(base32
- "0yfq3l561808bh9ahp245a14ikh2li8k67nvk3rjdpxciwkvmqvw"))))
+ "1ip4al2k6q814i7m1ydank9jdl2k8ckmrg1bjffz28qr0m3ygl7m"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f)) ; tests not included
@@ -2064,17 +2056,37 @@ minutes of work.
(home-page "http://www.rubyonrails.org")
(license license:expat)))
+(define-public ruby-erubi
+ (package
+ (name "ruby-erubi")
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "erubi" version))
+ (sha256
+ (base32
+ "1zkaqb8zv14azb2fa8w79d3mssdx86k9kg2m1bgc2k428y2zf8g9"))))
+ (build-system ruby-build-system)
+ (synopsis
+ "Erubi is a ERB template engine for ruby. It is a simplified fork of Erubis")
+ (description
+ "Erubi is a ERB template engine for ruby. It is a simplified fork of Erubis")
+ (home-page
+ "https://github.com/jeremyevans/erubi")
+ (license license:expat)))
+
(define-public ruby-actionview
(package
(name "ruby-actionview")
- (version "5.0.0")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "actionview" version))
(sha256
(base32
- "10f9d1jl945vr0l4sfr8v7rf3lkdbq33f5yvnx36aa2vskz529m1"))))
+ "1hhpljazbc89fpfxdz72vxgsnv236sqk8n92ykk1hy1khs53jbrh"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f)) ; tests not included
@@ -2085,7 +2097,8 @@ minutes of work.
("ruby-rails-dom-testing"
,ruby-rails-dom-testing)
("ruby-rails-html-sanitizer"
- ,ruby-rails-html-sanitizer)))
+ ,ruby-rails-html-sanitizer)
+ ("ruby-erubi" ,ruby-erubi)))
(synopsis
"Simple, battle-tested conventions and helpers for building web pages.")
(description
@@ -2096,14 +2109,14 @@ minutes of work.
(define-public ruby-activejob
(package
(name "ruby-activejob")
- (version "5.0.0")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "activejob" version))
(sha256
(base32
- "1xrchgz6xm5j2wqfqhh6qixvssv37hsdpyi4m2zb1m53qjn0q3pv"))))
+ "1jkbrfhhnwww468sw6x64pwcpjskxjnwas2gfzvgg4km9bglz0gp"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f))
@@ -2120,14 +2133,14 @@ minutes of work.
(define-public ruby-activemodel
(package
(name "ruby-activemodel")
- (version "5.0.0")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "activemodel" version))
(sha256
(base32
- "11j5rixlcp3i8a5mxfl4b0yhac3kzzhgmvcibbnphy5x974nr8aa"))))
+ "0qws28wsgbh4hyx92zjip979xczq7dsblfhplzrxsjg1aj7ss220"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f))
@@ -2143,14 +2156,14 @@ minutes of work.
(define-public ruby-activerecord
(package
(name "ruby-activerecord")
- (version "5.0.0")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "activerecord" version))
(sha256
(base32
- "1sl1f0capcdfvvabsc3cxfrdq78nwafp1340zq6gxqrwkvab1nxq"))))
+ "0gj1nap7dn8fcx1nvni79zvl034jp6113sjjrr3hq1v2r5s7igl9"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f))
@@ -2168,14 +2181,14 @@ minutes of work.
(define-public ruby-railties
(package
(name "ruby-railties")
- (version "5.0.0")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "railties" version))
(sha256
(base32
- "0jrp9752vsfm8jz7mz8spns2cgzhg374hn1nrrnjl433rkjr6b3r"))))
+ "00c0laqxcsa243nv7dzln4x9vyxwvv63lg53b15n63w1nhrg6xz4"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f)) ; tests not included
@@ -2218,17 +2231,18 @@ minutes of work.
(define-public ruby-nio4r
(package
(name "ruby-nio4r")
- (version "1.2.1")
+ (version "2.2.0")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "nio4r" version))
(sha256
(base32
- "1adnm77xfxck0mrvid5d7lwng783gh580rh3y18nq4bwdikr6nha"))))
+ "0jjrj7vs29w6dfgsxq08226jfbi2j0x62lf4p9zmvyp19dj4z00a"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"
+ `(#:tests? #f
+ #:test-target "spec"
#:phases
(modify-phases %standard-phases
(add-before 'check 'fix-dependencies
@@ -2318,7 +2332,7 @@ minutes of work.
(define-public ruby-rails-dom-testing
(package
(name "ruby-rails-dom-testing")
- (version "2.0.1")
+ (version "2.0.3")
(source
(origin
(method url-fetch)
@@ -2329,7 +2343,7 @@ minutes of work.
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "17pb4nns4cl6nnh6vxldm086cvhc02vhgy1d5mm0imwpqjb0pb6q"))))
+ "1vf09h849gjqdisvdn6pgp2j7i8fixv8rdj6636prm4f2xh0f1g0"))))
(build-system ruby-build-system)
(native-inputs
`(("bundler" ,bundler)))
@@ -2580,7 +2594,8 @@ https://github.com/flavorjones/loofah-activerecord).")
"1fnn3fli5wkzyjl4ryh0k90316shqjfnhydmc7f8lqpi0q21va43"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"))
+ `(#:tests? #f
+ #:test-target "spec"))
(native-inputs
`(("bundler" ,bundler)
("ruby-rspec" ,ruby-rspec)
@@ -2912,15 +2927,17 @@ percentage, bars of various formats, elapsed time and estimated time remaining.
(define-public ruby-jquery-rails
(package
(name "ruby-jquery-rails")
- (version "4.1.1")
+ (version "4.3.1")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "jquery-rails" version))
(sha256
(base32
- "1asbrr9hqf43q9qbjf87f5lm7fp12pndh76z89ks6jwxf1350fj1"))))
+ "02ii77vwxc49f2lrkbdzww2168bp5nihwzakc9mqyrsbw394w7ki"))))
(build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
(native-inputs
`(("bundler" ,bundler)))
(propagated-inputs
@@ -2963,14 +2980,14 @@ percentage, bars of various formats, elapsed time and estimated time remaining.
(define-public ruby-jbuilder
(package
(name "ruby-jbuilder")
- (version "2.6.0")
+ (version "2.7.0")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "jbuilder" version))
(sha256
(base32
- "1jbh1296imd0arc9nl1m71yfd7kg505p8srr1ijpsqv4hhbz5qci"))))
+ "1n3myqk2hdnidzzbgcdz2r1y4cr5vpz5nkfzs0lz4y9gkjbjyh2j"))))
(build-system ruby-build-system)
(arguments
`(#:phases
@@ -3228,7 +3245,8 @@ will probably be an issue and hence this gem.")
"1r06gar8zp4hyzyc0ky7n6mybjj542lrfda5y78fm5hyhiplv104"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"))
+ `(#:tests? #f
+ #:test-target "spec"))
(native-inputs
`(("bundler" ,bundler)
("ruby-rspec" ,ruby-rspec-2)))
@@ -3511,3 +3529,218 @@ will probably be an issue and hence this gem.")
"http://github.com/technicalpickles/rspec-spies")
(license #f)))
+
+(define-public ruby-autoprefixer-rails
+(package
+ (name "ruby-autoprefixer-rails")
+ (version "7.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "autoprefixer-rails" version))
+ (sha256
+ (base32
+ "12jiv0nigfcnzn03w8avv6ivr9hwx4hqd28758yvsrfdzq31i05a"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (propagated-inputs
+ `(("ruby-execjs" ,ruby-execjs)))
+ (synopsis
+ "Parse CSS and add vendor prefixes to CSS rules using values from the Can I Use website.")
+ (description
+ "Parse CSS and add vendor prefixes to CSS rules using values from the Can I Use website.")
+ (home-page
+ "https://github.com/ai/autoprefixer-rails")
+ (license license:expat)))
+
+(define-public ruby-bootstrap-sass
+(package
+ (name "ruby-bootstrap-sass")
+ (version "3.3.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "bootstrap-sass" version))
+ (sha256
+ (base32
+ "1bc9bf6caddqn1rv15b5x56yczmbjzaxzl9lk5zbwrg1bfph4bx9"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-autoprefixer-rails"
+ ,ruby-autoprefixer-rails)
+ ("ruby-sass" ,ruby-sass)))
+ (synopsis
+ "bootstrap-sass is a Sass-powered version of Bootstrap 3, ready to drop right into your Sass powered applications.")
+ (description
+ "bootstrap-sass is a Sass-powered version of Bootstrap 3, ready to drop right into your Sass powered applications.")
+ (home-page
+ "https://github.com/twbs/bootstrap-sass")
+ (license license:expat)))
+
+(define-public ruby-multi-xml
+ (package
+ (name "ruby-multi-xml")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "multi_xml" version))
+ (sha256
+ (base32
+ "0lmd4f401mvravi1i1yq7b2qjjli0yq7dfc4p1nj5nwajp7r6hyj"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "Provides swappable XML backends utilizing LibXML, Nokogiri, Ox, or REXML.")
+ (description
+ "Provides swappable XML backends utilizing LibXML, Nokogiri, Ox, or REXML.")
+ (home-page "https://github.com/sferik/multi_xml")
+ (license license:expat)))
+
+(define-public ruby-omniauth-oauth2
+ (package
+ (name "ruby-omniauth-oauth2")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "omniauth-oauth2" version))
+ (sha256
+ (base32
+ "0mskwlw5ibx9mz7ywqji6mm56ikf7mglbnfc02qhg6ry527jsxdm"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-oauth2" ,ruby-oauth2)
+ ("ruby-omniauth" ,ruby-omniauth)))
+ (synopsis
+ "An abstract OAuth2 strategy for OmniAuth.")
+ (description
+ "An abstract OAuth2 strategy for OmniAuth.")
+ (home-page
+ "https://github.com/omniauth/omniauth-oauth2")
+ (license license:expat)))
+
+(define-public ruby-jwt
+ (package
+ (name "ruby-jwt")
+ (version "1.5.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jwt" version))
+ (sha256
+ (base32
+ "124zz1142bi2if7hl5pcrcamwchv4icyr5kaal9m2q6wqbdl6aw4"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "A pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
+ (description
+ "This package provides a pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
+ (home-page "http://github.com/jwt/ruby-jwt")
+ (license license:expat)))
+
+(define-public ruby-oauth2
+ (package
+ (name "ruby-oauth2")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "oauth2" version))
+ (sha256
+ (base32
+ "094hmmfms8vpm6nwglpl7jmlv85nlfzl0kik4fizgx1rg70a6mr5"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-faraday" ,ruby-faraday)
+ ("ruby-jwt" ,ruby-jwt)
+ ("ruby-multi-json" ,ruby-multi-json)
+ ("ruby-multi-xml" ,ruby-multi-xml)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "A Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
+ (description
+ "This package provides a Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
+ (home-page "http://github.com/intridea/oauth2")
+ (license license:expat)))
+
+(define-public ruby-omniauth
+ (package
+ (name "ruby-omniauth")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "omniauth" version))
+ (sha256
+ (base32
+ "1msqr4qq7mfdvl3rg89529isrv595hvjpj2gi0say4b8nwqfggmg"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-hashie" ,ruby-hashie)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "A generalized Rack framework for multiple-provider authentication.")
+ (description
+ "This package provides a generalized Rack framework for multiple-provider authentication.")
+ (home-page
+ "https://github.com/omniauth/omniauth")
+ (license license:expat)))
+
+(define-public ruby-warden
+ (package
+ (name "ruby-warden")
+ (version "1.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "warden" version))
+ (sha256
+ (base32
+ "0va966lhpylcwbqb9n151kkihx30agh0a57mwjwdxyanll4s1q12"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs `(("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "Rack middleware that provides authentication for rack applications")
+ (description
+ "Rack middleware that provides authentication for rack applications")
+ (home-page "http://github.com/hassox/warden")
+ (license license:expat)))
+
+(define-public ruby-warden-oauth2
+ (package
+ (name "ruby-warden-oauth2")
+ (version "0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "warden-oauth2" version))
+ (sha256
+ (base32
+ "1z9154lvzrnnfjbjkmirh4n811nygp6pm2fa6ikr7y1ysa4zv3cz"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-warden" ,ruby-warden)))
+ (synopsis "OAuth 2.0 strategies for Warden")
+ (description "OAuth 2.0 strategies for Warden")
+ (home-page
+ "https://github.com/opperator/warden-oauth2")
+ (license #f)))
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0f84d79ae6..6f607629b1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2992,7 +2992,8 @@ alternative to Marshal for Object serialization. ")
"00vhasqwc4f98qb4wxqn2h07fjwzhp5lwyi41j2gndi2g02wrdqh"))))
(build-system ruby-build-system)
(arguments
- '(#:test-target "spec"))
+ '(#:tests? #f
+ #:test-target "spec"))
(native-inputs
`(("ruby-rake-compiler" ,ruby-rake-compiler)
("ruby-hoe" ,ruby-hoe)
@@ -3543,7 +3544,9 @@ used to create both network servers and clients.")
"1d0sd4q50zkcqhr395wj1wpn2ql52r0fpwhzjfvi1bljml7k546v"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
+ `(;; Could not find gem 'rake (~> 10.0)' in any of the gem sources listed in your Gemfile.
+ #:tests? #f
+ #:phases
(modify-phases %standard-phases
(add-before 'check 'clean-up
(lambda _
@@ -3563,6 +3566,7 @@ used to create both network servers and clients.")
#t)))))
(native-inputs
`(("bundler" ,bundler)
+ ("ruby-rake" ,ruby-rake)
("ruby-rspec" ,ruby-rspec-2)))
(synopsis "Simplifies checking for Ruby implementation")
(description
@@ -4734,3 +4738,162 @@ thing this library does today is convert org-mode files to HTML or Textile or
Markdown.")
(home-page "https://github.com/wallyqs/org-ruby")
(license license:expat)))
+
+(define-public ruby-rake
+ (package
+ (name "ruby-rake")
+ (version "11.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rake" version))
+ (sha256
+ (base32
+ "0m7fk7n0q459b1866cpq0gyz6904srhajrag0ybpdyl5sw4c2xff"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (synopsis
+ "Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
+specified in standard Ruby syntax.")
+ (description
+ "Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
+specified in standard Ruby syntax.")
+ (home-page "https://github.com/ruby/rake")
+ (license license:expat)))
+
+(define-public ruby-open4
+ (package
+ (name "ruby-open4")
+ (version "1.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "open4" version))
+ (sha256
+ (base32
+ "1cgls3f9dlrpil846q0w7h66vsc33jqn84nql4gcqkk221rh7px1"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their io handles easily.")
+ (description
+ "open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their io handles easily.")
+ (home-page "https://github.com/ahoward/open4")
+ (license #f)))
+
+(define-public ruby-hamster
+ (package
+ (name "ruby-hamster")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "hamster" version))
+ (sha256
+ (base32
+ "1n1lsh96vnyc1pnzyd30f9prcsclmvmkdb3nm5aahnyizyiy6lar"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-concurrent" ,ruby-concurrent)))
+ (synopsis
+ "Efficient, immutable, thread-safe collection classes for Ruby")
+ (description
+ "Efficient, immutable, thread-safe collection classes for Ruby")
+ (home-page
+ "https://github.com/hamstergem/hamster")
+ (license license:expat)))
+
+(define-public ruby-lino
+ (package
+ (name "ruby-lino")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "lino" version))
+ (sha256
+ (base32
+ "11d29g0fk372b9fcpyr0k6hxm2b4j4igpysmi542hgbbgqgp9cd3"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-hamster" ,ruby-hamster)
+ ("ruby-open4" ,ruby-open4)))
+ (synopsis "Command line builders and executors.")
+ (description
+ "Command line builders and executors.")
+ (home-page "https://github.com/tobyclemson/lino")
+ (license license:expat)))
+
+(define-public ruby-terraform
+ (package
+ (name "ruby-terraform")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ruby-terraform" version))
+ (sha256
+ (base32
+ "1ql3p39g7pax77i2in26qb51qa6i61k8jzqg7al1236zfz5bnxap"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs `(("ruby-lino" ,ruby-lino)))
+ (synopsis
+ "Wraps the Terraform CLI so that Terraform can be invoked from a Ruby script or Rakefile.")
+ (description
+ "Wraps the Terraform CLI so that Terraform can be invoked from a Ruby script or Rakefile.")
+ (home-page
+ "https://github.com/tobyclemson/ruby_terraform")
+ (license license:expat)))
+
+(define-public ruby-sucker-punch
+ (package
+ (name "ruby-sucker-punch")
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "sucker_punch" version))
+ (sha256
+ (base32
+ "064dgfg3jwna2x1iyhbz3pvh3iryxs4vls77jmmad571hjz0l01p"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-concurrent" ,ruby-concurrent)))
+ (synopsis
+ "Asynchronous processing library for Ruby")
+ (description
+ "Asynchronous processing library for Ruby")
+ (home-page
+ "https://github.com/brandonhilkert/sucker_punch")
+ (license license:expat)))
+
+(define-public ruby-que
+(package
+ (name "ruby-que")
+ (version "0.14.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "que" version))
+ (sha256
+ (base32
+ "08krk70sff9q01dm2jc5z4zlczri1wj3zgz1xk33saz7g3pkf7sd"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "A job queue that uses PostgreSQL's advisory locks for speed and reliability.")
+ (description
+ "This package provides a job queue that uses PostgreSQL's advisory locks for speed and reliability.")
+ (home-page "https://github.com/chanks/que")
+ (license license:expat)))