aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-01-01 00:12:06 +1000
committerChristopher Baines <mail@cbaines.net>2018-01-27 13:41:18 +0000
commitc687d149647a2ea5469836eca3d78b31c99f5f69 (patch)
tree9de3b67ce7c22d0474a11d754e2657d14a247fb4
parent9a21b8ebb14585711e1940d4f6747781af901c6e (diff)
downloadguix-c687d149647a2ea5469836eca3d78b31c99f5f69.tar
guix-c687d149647a2ea5469836eca3d78b31c99f5f69.tar.gz
gnu: Add ruby-sporkmonger-rack-mount.
* gnu/packages/ruby.scm (ruby-sporkmonger-rack-mount): New variable.
-rw-r--r--gnu/packages/ruby.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e66c6d6541..ffadbbd2c5 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -689,6 +689,37 @@ AsciiDoc content to HTML5, DocBook 5 (or 4.5) and other formats.")
(home-page "http://asciidoctor.org")
(license license:expat)))
+(define-public ruby-sporkmonger-rack-mount
+ ;; Testing the addressable gem requires a newer commit than that released, so
+ ;; use an up to date version.
+ (let ((revision "1")
+ (commit "076aa2c47d9a4c081f1e9bcb56a826a9e72bd5c3"))
+ (package
+ (name "ruby-sporkmonger-rack-mount")
+ (version (string-append "0.8.3." revision "." commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sporkmonger/rack-mount.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1scx273g3xd93424x9lxc4zyvcp2niknbw5mkz6wkivpf7xsyxdq"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; Tests currently fail so disable them.
+ ;; https://github.com/sporkmonger/rack-mount/pull/1
+ `(#:tests? #f))
+ (propagated-inputs `(("ruby-rack" ,ruby-rack)))
+ (synopsis "Stackable dynamic tree based Rack router")
+ (description
+ "@code{Rack::Mount} supports Rack's @code{X-Cascade} convention to
+continue trying routes if the response returns pass. This allows multiple
+routes to be nested or stacked on top of each other.")
+ (home-page "https://github.com/sporkmonger/rack-mount")
+ (license license:expat))))
+
(define-public ruby-ci-reporter
(package
(name "ruby-ci-reporter")