aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2018-01-20 01:54:53 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-23 10:18:22 +0100
commitbfe88e0c6e8e6f548810ce937170a5e5c560b368 (patch)
treea02ab1dbe5346702cf915c967f49c9d3af18038b
parent8bf127d5ab5f95dc606fbec2b8de5c942dd79b9d (diff)
downloadguix-bfe88e0c6e8e6f548810ce937170a5e5c560b368.tar
guix-bfe88e0c6e8e6f548810ce937170a5e5c560b368.tar.gz
gnu: Add 'pyconfigure'.
* gnu/packages/autotools.scm (pyconfigure): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/autotools.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 8a906a7d4a..68c30ad563 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -27,6 +27,7 @@
#:use-module (guix licenses)
#:use-module (gnu packages)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages python)
#:use-module (gnu packages m4)
#:use-module (gnu packages man)
#:use-module (gnu packages bash)
@@ -420,3 +421,38 @@ complexity of working with shared libraries across platforms.")
(description (package-description libtool))
(home-page (package-home-page libtool))
(license lgpl2.1+)))
+
+(define-public pyconfigure
+ (package
+ (name "pyconfigure")
+ (version "0.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/pyconfigure/pyconfigure-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0kxi9bg7l6ric39vbz9ykz4a21xlihhh2zcc3297db8amvhqwhrp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-python
+ (lambda _
+ (substitute* "pyconf.in"
+ (("/usr/bin/env python") (which "python3")))
+ #t)))))
+ (inputs
+ `(("python" ,python-3)))
+ (synopsis "@command{configure} interface for Python-based packages")
+ (description
+ "GNU pyconfigure provides template files for easily implementing
+standards-compliant configure scripts and Makefiles for Python-based packages.
+It is designed to work alongside existing Python setup scripts, making it easy
+to integrate into existing projects. Powerful and flexible Autoconf macros
+are available, allowing you to easily make adjustments to the installation
+procedure based on the capabilities of the target computer.")
+ (home-page "https://www.gnu.org/software/pyconfigure/manual/")
+ (license
+ (fsf-free
+ "https://www.gnu.org/prep/maintain/html_node/License-Notices-for-Other-Files.html"))))