aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-31 23:08:21 +1000
committerChristopher Baines <mail@cbaines.net>2018-01-27 13:41:18 +0000
commit24bee8d9dc95fe0c13b09f01a8ed72b46811f7e2 (patch)
tree30180af8580e75fa71a1ef41d617af0e8d68a1c0
parentb0004e1e46f3374dba2bc3cdf82f16959e138c30 (diff)
downloadguix-24bee8d9dc95fe0c13b09f01a8ed72b46811f7e2.tar
guix-24bee8d9dc95fe0c13b09f01a8ed72b46811f7e2.tar.gz
gnu: Add ruby-asciidoctor.
* gnu/packages/ruby.scm (ruby-asciidoctor): New variable.
-rw-r--r--gnu/packages/ruby.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 466a7a9edc..3daa8eb8db 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -654,6 +654,41 @@ easy-to-write markup language for mathematics.")
(home-page "https://github.com/pepijnve/asciimath")
(license license:expat)))
+(define-public ruby-asciidoctor
+ (package
+ (name "ruby-asciidoctor")
+ (version "1.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "asciidoctor" version))
+ (sha256
+ (base32
+ "0q9yhan2mkk1lh15zcfd9g2fn6faix9yrf5skg23dp1y77jv7vm0"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "test:all"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'remove-circular-tests
+ (lambda _
+ ;; Remove tests that require circular dependencies to load or pass.
+ (delete-file "test/invoker_test.rb")
+ (delete-file "test/converter_test.rb")
+ (delete-file "test/options_test.rb")
+ #t)))))
+ (native-inputs
+ `(("ruby-minitest" ,ruby-minitest)
+ ("ruby-nokogiri" ,ruby-nokogiri)
+ ("ruby-asciimath" ,ruby-asciimath)
+ ("ruby-coderay" ,ruby-coderay)))
+ (synopsis "Converter from AsciiDoc content to other formats")
+ (description
+ "Asciidoctor is a text processor and publishing toolchain for converting
+AsciiDoc content to HTML5, DocBook 5 (or 4.5) and other formats.")
+ (home-page "http://asciidoctor.org")
+ (license license:expat)))
+
(define-public ruby-ci-reporter
(package
(name "ruby-ci-reporter")