aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-09-24 20:31:32 +0200
committerBrian Leung <leungbk@mailfence.com>2019-09-24 20:34:08 +0200
commite4cf01c003f070ac494f6ac5d65a04a1c755ac6b (patch)
treeb84d9d1559b8fc2eba1b7557fcdbebeb2303c3bf
parentaa0e28bc73487f2298b494ab077526ba448a1c57 (diff)
downloadguix-e4cf01c003f070ac494f6ac5d65a04a1c755ac6b.tar
guix-e4cf01c003f070ac494f6ac5d65a04a1c755ac6b.tar.gz
gnu: emacs-stream: Update to 2.2.4-1.a3f3da1.
* gnu/packages/emacs-xyz.scm (emacs-stream): Update to 2.2.4-1.a3f3da1.
-rw-r--r--gnu/packages/emacs-xyz.scm46
1 files changed, 24 insertions, 22 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 58e7f181d5..1869345dca 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7467,29 +7467,31 @@ editing nginx config files.")
(license license:gpl2+)))
(define-public emacs-stream
- (package
- (name "emacs-stream")
- (version "2.2.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/NicolasPetton/stream.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "10x481lmkcmjrmdnlbqvys2b3525npn4a84j6g404pv4sfwlj6ab"))))
- (build-system emacs-build-system)
- (arguments
- `(#:tests? #t
- #:test-command '("emacs" "--batch"
- "-l" "test/stream-tests.el"
- "-f" "ert-run-tests-batch-and-exit")))
- (home-page "https://github.com/NicolasPetton/stream")
- (synopsis "Implementation of streams for Emacs")
- (description "This library provides an implementation of streams for Emacs.
+ (let ((commit "a3f3da155a49c133e2692bd8789b35492bfdc4f7")
+ (revision "1"))
+ (package
+ (name "emacs-stream")
+ (version (git-version "2.2.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Emacsmirror/stream.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0aig0yjb9z752ijh0mzildjmh44j051inchga8qll01dr8wf7332"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "--batch"
+ "-l" "tests/stream-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")))
+ (home-page "https://github.com/Emacsmirror/stream")
+ (synopsis "Implementation of streams for Emacs")
+ (description "This library provides an implementation of streams for Emacs.
Streams are implemented as delayed evaluation of cons cells.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-el-search
(let ((commit "f26277bfbb3fc3fc74beea6592f294c439796bd4")