aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-09-24 11:32:45 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-09-24 11:32:54 +0200
commitb150e83bef766ca67a3931afce36b6cb6c7f8c10 (patch)
tree1f6c66a08fd8639db1dad8ff321c7979e7edd5ec
parent3429f5d923300675a8ffa28b2d4cb1bd66ae452e (diff)
downloadguix-b150e83bef766ca67a3931afce36b6cb6c7f8c10.tar
guix-b150e83bef766ca67a3931afce36b6cb6c7f8c10.tar.gz
gnu: Add mojoshader-with-viewport-flip.
* gnu/packages/gl.scm (mojoshader-with-viewport-flip): New variable.
-rw-r--r--gnu/packages/gl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index c02d88694c..bfa80b1e13 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -858,3 +858,26 @@ MojoShader provides both a simple API to convert bytecode to various profiles,
and (optionally) basic glue to rendering APIs to abstract the management of
the shaders at runtime.")
(license license:zlib))))
+
+(define-public mojoshader-with-viewport-flip
+ ;; Changeset c586d4590241 replaced glProgramViewportFlip with
+ ;; glProgramViewportInfo.
+ ;; https://hg.icculus.org/icculus/mojoshader/rev/c586d4590241
+ (let ((changeset "2e37299b13d8"))
+ (package
+ (inherit mojoshader)
+ (name "mojoshader-with-viewport-flip")
+ (version (string-append "20190725" "-" changeset))
+ (source
+ (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "https://hg.icculus.org/icculus/mojoshader/")
+ (changeset changeset)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ffws7cqbskxwc3hjsnnzq4r2bbf008kdr3b11pa3kr7dsi50y6i"))))
+ (synopsis "Work with Direct3D shaders on alternate 3D APIs (with viewport flip)")
+ (description "This is the last version of the mojoshader library with
+the glProgramViewportFlip before it was replaced with glProgramViewportInfo.")
+ (license license:zlib))))