aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-09-23 16:43:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-09-23 17:58:32 +0200
commitaa686627ac2ca2ab43d6423595223348177f7f80 (patch)
tree09ef2712870a3178c2a9c8300d8862d4d54fb479
parentbfe194b5331fe9a60ed9e1d373fe1de9e2606d34 (diff)
downloadguix-aa686627ac2ca2ab43d6423595223348177f7f80.tar
guix-aa686627ac2ca2ab43d6423595223348177f7f80.tar.gz
gnu: python-slugify: Update to 3.0.4.
* gnu/packages/python-web.scm (python-slugify): Update to 3.0.4. * gnu/packages/patches/python-slugify-depend-on-unidecode.patch: Adjust accordingly.
-rw-r--r--gnu/packages/patches/python-slugify-depend-on-unidecode.patch4
-rw-r--r--gnu/packages/python-web.scm5
2 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/patches/python-slugify-depend-on-unidecode.patch b/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
index 6038f432f1..5ac749c19d 100644
--- a/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
+++ b/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
@@ -6,8 +6,8 @@ index 4800173..6bdd77f 100755
author = 'Val Neekman'
author_email = 'info@neekware.com'
license = 'MIT'
--install_requires = ['text-unidecode==1.2']
--extras_require = {'unidecode': ['Unidecode==1.0.23']}
+-install_requires = ['text-unidecode>=1.3']
+-extras_require = {'unidecode': ['Unidecode>=1.1.1']}
+install_requires = ['Unidecode']
classifiers = [
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9b88d66118..0c93c03adf 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3219,14 +3219,13 @@ Python.")
(define-public python-slugify
(package
(name "python-slugify")
- (version "3.0.2")
+ (version "3.0.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-slugify" version))
(sha256
- (base32
- "0n6pfmsq899c54plpvzi46l7zrpa3zfpm8im6h32czjw6kxky5jp"))
+ (base32 "0dv97yi5fq074q5qyqbin09pmi8ixg36caf5nkpw2bqkd8jh6pap"))
(patches
(search-patches "python-slugify-depend-on-unidecode.patch"))))
(native-inputs