aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-15 14:01:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 14:05:37 +0100
commit9949f459bff3980f59db8925a90891577e4f91d6 (patch)
treea8e771117abe7d0a05e6f0e644ba2d3fdf59ca9e
parentd64e3a487ba890b1aa6b24b7be917f55f80740a8 (diff)
downloadguix-9949f459bff3980f59db8925a90891577e4f91d6.tar
guix-9949f459bff3980f59db8925a90891577e4f91d6.tar.gz
gnu: r-iranges: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-iranges): Move from here... * gnu/packages/bioconductor.scm (r-iranges): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm30
-rw-r--r--gnu/packages/bioinformatics.scm29
2 files changed, 30 insertions, 29 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ed34a9308a..68c5ed7768 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018, 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
+;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020, 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Peter Lo <peterloleungyau@gmail.com>
@@ -1244,6 +1245,35 @@ and evaluate clustering results.")
arbitrary genomic intervals along chromosomal ideogram.")
(license license:gpl2)))
+(define-public r-iranges
+ (package
+ (name "r-iranges")
+ (version "2.24.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "IRanges" version))
+ (sha256
+ (base32
+ "01mx46a82vd3gz705pj0kk4wpxg683s8jqxchzjia3gz00b4qw52"))))
+ (properties
+ `((upstream-name . "IRanges")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-s4vectors" ,r-s4vectors)))
+ (home-page "https://bioconductor.org/packages/IRanges")
+ (synopsis "Infrastructure for manipulating intervals on sequences")
+ (description
+ "This package provides efficient low-level and highly reusable S4 classes
+for storing ranges of integers, RLE vectors (Run-Length Encoding), and, more
+generally, data that can be organized sequentially (formally defined as
+@code{Vector} objects), as well as views on these @code{Vector} objects.
+Efficient list-like classes are also provided for storing big collections of
+instances of the basic classes. All classes in the package use consistent
+naming and share the same rich and consistent \"Vector API\" as much as
+possible.")
+ (license license:artistic2.0)))
+
;; This is a CRAN package, but it depends on r-bsgenome-hsapiens-ucsc-hg19
;; from Bioconductor.
(define-public r-deconstructsigs
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1fcb436f0d..36ecf47467 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7691,35 +7691,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-iranges
- (package
- (name "r-iranges")
- (version "2.24.1")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "IRanges" version))
- (sha256
- (base32
- "01mx46a82vd3gz705pj0kk4wpxg683s8jqxchzjia3gz00b4qw52"))))
- (properties
- `((upstream-name . "IRanges")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biocgenerics" ,r-biocgenerics)
- ("r-s4vectors" ,r-s4vectors)))
- (home-page "https://bioconductor.org/packages/IRanges")
- (synopsis "Infrastructure for manipulating intervals on sequences")
- (description
- "This package provides efficient low-level and highly reusable S4 classes
-for storing ranges of integers, RLE vectors (Run-Length Encoding), and, more
-generally, data that can be organized sequentially (formally defined as
-@code{Vector} objects), as well as views on these @code{Vector} objects.
-Efficient list-like classes are also provided for storing big collections of
-instances of the basic classes. All classes in the package use consistent
-naming and share the same rich and consistent \"Vector API\" as much as
-possible.")
- (license license:artistic2.0)))
-
(define-public r-genomeinfodbdata
(package
(name "r-genomeinfodbdata")