aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-15 14:42:46 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-15 15:53:16 +0200
commit6f655caf42f52568180bbeee382c955abf0838cf (patch)
tree102f301dd3251efd5055f775140bfcf1d34651a3
parentfb6f926193b3f63a2cd4ab539cbffae68b96da67 (diff)
downloadguix-6f655caf42f52568180bbeee382c955abf0838cf.tar
guix-6f655caf42f52568180bbeee382c955abf0838cf.tar.gz
gnu: rust-wayland-server-0.28: Adapt for new build system.
* gnu/packages/crates-graphics.scm (rust-wayland-server-0.28) [arguments]: Don't skip build. Remove rust-wayland-commons-0.28, rust-wayland-scanner-0.28, rust-wayland-sys-0.28 from cargo-inputs. [inputs]: Add rust-bitflags-1, rust-downcast-rs-1, rust-lazy-static-1, rust-libc-0.2, rust-nix-0.18, rust-parking-lot-0.18, rust-scoped-tls-1, rust-wayland-commons-0.28, rust-wayland-scanner-0.28, rust-wayland-sys-0.28. (rust-wayland-server-0.23): Adjust accordingly.
-rw-r--r--gnu/packages/crates-graphics.scm25
1 files changed, 17 insertions, 8 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 71719fe3ed..e0bca86647 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2682,18 +2682,25 @@ wayland-client crate for usable bindings.")
(base32 "09jfdjfqhjfcpiz4csgh60ymfkmz1cl3jmxyzq9hzcp0kyyxix93"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-bitflags" ,rust-bitflags-1)
("rust-downcast-rs" ,rust-downcast-rs-1)
("rust-lazy-static" ,rust-lazy-static-1)
("rust-libc" ,rust-libc-0.2)
("rust-nix" ,rust-nix-0.18)
("rust-parking-lot" ,rust-parking-lot-0.11)
- ("rust-scoped-tls" ,rust-scoped-tls-1)
- ("rust-wayland-commons" ,rust-wayland-commons-0.28)
- ("rust-wayland-scanner" ,rust-wayland-scanner-0.28)
- ("rust-wayland-sys" ,rust-wayland-sys-0.28))))
+ ("rust-scoped-tls" ,rust-scoped-tls-1))))
+ (inputs
+ `(("rust-bitflags" ,rust-bitflags-1)
+ ("rust-downcast-rs" ,rust-downcast-rs-1)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-nix" ,rust-nix-0.18)
+ ("rust-parking-lot" ,rust-parking-lot-0.11)
+ ("rust-scoped-tls" ,rust-scoped-tls-1)
+ ("rust-wayland-commons" ,rust-wayland-commons-0.28)
+ ("rust-wayland-scanner" ,rust-wayland-scanner-0.28)
+ ("rust-wayland-sys" ,rust-wayland-sys-0.28)))
(home-page "https://github.com/smithay/wayland-rs")
(synopsis
"Bindings to the standard C implementation of the wayland protocol")
@@ -2717,7 +2724,8 @@ the wayland protocol, server side.")
(base32
"1ccsalq6gnf07klnbjx2dxcbibhw03rqsgi578p913s3zsjlcg8a"))))
(arguments
- `(#:cargo-inputs
+ `(#:skip-build? #t
+ #:cargo-inputs
(("rust-bitflags" ,rust-bitflags-1)
("rust-calloop" ,rust-calloop-0.4)
("rust-downcast-rs" ,rust-downcast-rs-1)
@@ -2726,7 +2734,8 @@ the wayland protocol, server side.")
("rust-nix" ,rust-nix-0.14)
("rust-wayland-commons" ,rust-wayland-commons-0.23)
("rust-wayland-sys" ,rust-wayland-sys-0.23)
- ("rust-wayland-scanner" ,rust-wayland-scanner-0.23))))))
+ ("rust-wayland-scanner" ,rust-wayland-scanner-0.23))))
+ (inputs `())))
(define-public rust-wayland-server-0.21
(package