aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-15 11:38:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 11:43:20 +0100
commit6e0ed09e687d9b8ae2cf2d01a9946b84bc8bf641 (patch)
tree0b04b0859a95f3ad8cf407c192493e355312a181
parentad34eb222c9ebc2b31f03b70ba6655ebe8ee74b5 (diff)
downloadguix-6e0ed09e687d9b8ae2cf2d01a9946b84bc8bf641.tar
guix-6e0ed09e687d9b8ae2cf2d01a9946b84bc8bf641.tar.gz
gnu: Add instrain.
* gnu/packages/bioinformatics.scm (instrain): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c629b79c39..b0736d32e4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13177,6 +13177,59 @@ similar genomes and choosing the best representative genome for each genome
set.")
(license license:expat)))
+(define-public instrain
+ (package
+ (name "instrain")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "inStrain" version))
+ (sha256
+ (base32
+ "0ykqlpf6yz4caihsaz3ys00cyvlr7wdj4s9a8rh56q5r8xf80ic0"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-relative-imports
+ (lambda _
+ (substitute* "docker/run_instrain.py"
+ (("from s3_utils")
+ "from .s3_utils")
+ (("from job_utils")
+ "from .job_utils")))))))
+ (inputs
+ `(("python-biopython" ,python-biopython)
+ ("python-boto3" ,python-boto3)
+ ("python-h5py" ,python-h5py)
+ ("python-lmfit" ,python-lmfit)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-networkx" ,python-networkx)
+ ("python-numba" ,python-numba)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-psutil" ,python-psutil)
+ ("python-pysam" ,python-pysam)
+ ("python-scikit-learn" ,python-scikit-learn)
+ ("python-seaborn" ,python-seaborn)
+ ("python-tqdm" ,python-tqdm)
+ ;; drep is needed for deprecated plot utilities
+ ("python-drep" ,python-drep)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/MrOlm/inStrain")
+ (synopsis "Calculation of strain-level metrics")
+ (description
+ "inStrain is a Python program for analysis of co-occurring genome
+populations from metagenomes that allows highly accurate genome comparisons,
+analysis of coverage, microdiversity, and linkage, and sensitive SNP detection
+with gene localization and synonymous non-synonymous identification.")
+ ;; The tool itself says that the license is "MIT", but the repository
+ ;; contains a LICENSE file with the GPLv3.
+ ;; See https://github.com/MrOlm/inStrain/issues/51
+ (license license:expat)))
+
(define-public gffcompare
(let ((commit "be56ef4349ea3966c12c6397f85e49e047361c41")
(revision "1"))