aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-15 13:39:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 13:45:29 +0100
commit3ebae705f993098a688eff88c07e75e52f5e67a6 (patch)
tree886e6dca3342319ce66ce4f37b463f517ea85ec3
parentddfe3f77a9354c166bdb6b09ae87e62a4c533eba (diff)
downloadguix-3ebae705f993098a688eff88c07e75e52f5e67a6.tar
guix-3ebae705f993098a688eff88c07e75e52f5e67a6.tar.gz
gnu: Add r-spatstat-core.
* gnu/packages/cran.scm (r-spatstat-core): New variable.
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c70c734a8c..5bc47ef53b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24886,6 +24886,38 @@ user-level code from spatstat which performs geometrical operations, except
for the geometry of linear networks.")
(license license:gpl2+)))
+(define-public r-spatstat-core
+ (package
+ (name "r-spatstat-core")
+ (version "1.65-5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "spatstat.core" version))
+ (sha256
+ (base32
+ "0wq61sd53hwyk3fzjdc2prrr66n67zbwb5i3ii7kvyhfwx0xikm3"))))
+ (properties `((upstream-name . "spatstat.core")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-abind" ,r-abind)
+ ("r-goftest" ,r-goftest)
+ ("r-matrix" ,r-matrix)
+ ("r-mgcv" ,r-mgcv)
+ ("r-nlme" ,r-nlme)
+ ("r-rpart" ,r-rpart)
+ ("r-spatstat-data" ,r-spatstat-data)
+ ("r-spatstat-geom" ,r-spatstat-geom)
+ ("r-spatstat-sparse" ,r-spatstat-sparse)
+ ("r-spatstat-utils" ,r-spatstat-utils)
+ ("r-tensor" ,r-tensor)))
+ (home-page "http://spatstat.org/")
+ (synopsis "Core functionality of the spatstat package")
+ (description
+ "This is a subset of the original spatstat package, containing all of the
+user-level code from spatstat, except for the code for linear networks.")
+ (license license:gpl2+)))
+
(define-public r-spatstat
(package
(name "r-spatstat")