aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-15 14:01:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 14:03:18 +0100
commit134404b437a2b17bbe072b263884f6ff5d8daf86 (patch)
tree2ac92165950934d3abbe20fe62dd264372539f34
parent53dff6ac8ffaeeaa704957b83b2245d4494b030a (diff)
downloadguix-134404b437a2b17bbe072b263884f6ff5d8daf86.tar
guix-134404b437a2b17bbe072b263884f6ff5d8daf86.tar.gz
gnu: r-biocviews: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-biocviews): Move from here... * gnu/packages/bioconductor.scm (r-biocviews): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm28
-rw-r--r--gnu/packages/bioinformatics.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 4f8e0562b1..c02d1c7877 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8477,6 +8477,34 @@ monograph.")
different graph related packages produced by Bioconductor.")
(license license:artistic2.0)))
+(define-public r-biocviews
+ (package
+ (name "r-biocviews")
+ (version "1.58.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "biocViews" version))
+ (sha256
+ (base32
+ "1by2639z7n62z84dr8rj9jz12gsd1k8q42zsnxacxbwfwp6h0cl4"))))
+ (properties
+ `((upstream-name . "biocViews")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocmanager" ,r-biocmanager)
+ ("r-graph" ,r-graph)
+ ("r-rbgl" ,r-rbgl)
+ ("r-rcurl" ,r-rcurl)
+ ("r-xml" ,r-xml)
+ ("r-runit" ,r-runit)))
+ (home-page "https://bioconductor.org/packages/biocViews")
+ (synopsis "Bioconductor package categorization helper")
+ (description "The purpose of biocViews is to create HTML pages that
+categorize packages in a Bioconductor package repository according to keywords,
+also known as views, in a controlled vocabulary.")
+ (license license:artistic2.0)))
+
(define-public r-experimenthub
(package
(name "r-experimenthub")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b0736d32e4..8169ff4f26 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7718,34 +7718,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-biocviews
- (package
- (name "r-biocviews")
- (version "1.58.1")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "biocViews" version))
- (sha256
- (base32
- "1by2639z7n62z84dr8rj9jz12gsd1k8q42zsnxacxbwfwp6h0cl4"))))
- (properties
- `((upstream-name . "biocViews")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biobase" ,r-biobase)
- ("r-biocmanager" ,r-biocmanager)
- ("r-graph" ,r-graph)
- ("r-rbgl" ,r-rbgl)
- ("r-rcurl" ,r-rcurl)
- ("r-xml" ,r-xml)
- ("r-runit" ,r-runit)))
- (home-page "https://bioconductor.org/packages/biocViews")
- (synopsis "Bioconductor package categorization helper")
- (description "The purpose of biocViews is to create HTML pages that
-categorize packages in a Bioconductor package repository according to keywords,
-also known as views, in a controlled vocabulary.")
- (license license:artistic2.0)))
-
(define-public r-biocstyle
(package
(name "r-biocstyle")