aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-15 14:01:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 14:06:16 +0100
commit082f3c54337aaba40b978dfa9963f8ed6f20123d (patch)
treec9b18af7d3bef7d72125d3378b52bd4511201045
parent35b62c044e45a3add35b62839b07030f704bf708 (diff)
downloadguix-082f3c54337aaba40b978dfa9963f8ed6f20123d.tar
guix-082f3c54337aaba40b978dfa9963f8ed6f20123d.tar.gz
gnu: r-edger: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-edger): Move from here... * gnu/packages/bioconductor.scm (r-edger): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm28
-rw-r--r--gnu/packages/bioinformatics.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b4456d13c8..fb0127b7ca 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1684,6 +1684,34 @@ testing. The package also provides functions for the visualization and
exploration of the results.")
(license license:gpl3+)))
+(define-public r-edger
+ (package
+ (name "r-edger")
+ (version "3.32.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "edgeR" version))
+ (sha256
+ (base32
+ "1gaic8qf6a6sy0bmydh1xzf52w0wnq31aanpvw3a30pfsi218bcp"))))
+ (properties `((upstream-name . "edgeR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-limma" ,r-limma)
+ ("r-locfit" ,r-locfit)
+ ("r-rcpp" ,r-rcpp)
+ ("r-statmod" ,r-statmod))) ;for estimateDisp
+ (home-page "http://bioinf.wehi.edu.au/edgeR")
+ (synopsis "EdgeR does empirical analysis of digital gene expression data")
+ (description "This package can do differential expression analysis of
+RNA-seq expression profiles with biological replication. It implements a range
+of statistical methodology based on the negative binomial distributions,
+including empirical Bayes estimation, exact tests, generalized linear models
+and quasi-likelihood tests. It be applied to differential signal analysis of
+other types of genomic data that produce counts, including ChIP-seq, SAGE and
+CAGE.")
+ (license license:gpl2+)))
+
(define-public r-genefilter
(package
(name "r-genefilter")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ff6996011e..dc0d7a2906 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7691,34 +7691,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-edger
- (package
- (name "r-edger")
- (version "3.32.1")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "edgeR" version))
- (sha256
- (base32
- "1gaic8qf6a6sy0bmydh1xzf52w0wnq31aanpvw3a30pfsi218bcp"))))
- (properties `((upstream-name . "edgeR")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-limma" ,r-limma)
- ("r-locfit" ,r-locfit)
- ("r-rcpp" ,r-rcpp)
- ("r-statmod" ,r-statmod))) ;for estimateDisp
- (home-page "http://bioinf.wehi.edu.au/edgeR")
- (synopsis "EdgeR does empirical analysis of digital gene expression data")
- (description "This package can do differential expression analysis of
-RNA-seq expression profiles with biological replication. It implements a range
-of statistical methodology based on the negative binomial distributions,
-including empirical Bayes estimation, exact tests, generalized linear models
-and quasi-likelihood tests. It be applied to differential signal analysis of
-other types of genomic data that produce counts, including ChIP-seq, SAGE and
-CAGE.")
- (license license:gpl2+)))
-
(define-public r-variantannotation
(package
(name "r-variantannotation")