aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-04 16:03:37 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-04 16:54:09 +0300
commitf0a51a2bda26f9cc1e0b54b48712bd7cc54408e9 (patch)
tree8db98cdae7306880e2d8b3e406911fe0174d6f8c
parentf776eb3f8703dd55adaa92c9431728fdd2ce6b59 (diff)
downloadguix-f0a51a2bda26f9cc1e0b54b48712bd7cc54408e9.tar
guix-f0a51a2bda26f9cc1e0b54b48712bd7cc54408e9.tar.gz
gnu: vulkan-loader: Skip tests on riscv64-linux.
* gnu/packages/vulkan.scm (vulkan-loader)[arguments]: Skip tests when building on riscv64-linux.
-rw-r--r--gnu/packages/vulkan.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index dfc073b379..b0d968938b 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020, 2023 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2022 Kaelyn Takata <kaelyn.alexi@protonmail.com>
@@ -27,6 +27,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix utils)
#:use-module (guix gexp)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
@@ -227,6 +228,8 @@ interpretation of the specifications for these languages.")
(build-system cmake-build-system)
(arguments
(list
+ #:tests? (not (or (%current-target-system)
+ (target-riscv64?)))
#:configure-flags
#~(list (string-append "-DVULKAN_HEADERS_INSTALL_DIR="
(dirname (dirname