aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-05-04 23:06:38 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-04 23:14:21 +0200
commitdc5430c9dc20ee53441995d9a89a90b0a86aeed3 (patch)
tree57f80a55e1a24d323c46ce02ec45741cf4b2c176
parent9e95be01d96b03f0335dc4ab5e80ee1723181a5b (diff)
downloadguix-dc5430c9dc20ee53441995d9a89a90b0a86aeed3.tar
guix-dc5430c9dc20ee53441995d9a89a90b0a86aeed3.tar.gz
gnu: python-fs: Remove indirect dependency on Rust when unsupported.
This allows to build font-abattis-cantarell on aarch64-linux. * gnu/packages/python-xyz.scm (python-fs)[arguments]: Add #:tests?. [native-inputs]: Turn into the empty list when cross-compiling or when PYTHON-PYFTPDLIB is not supported.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 195ab725a7..6c8fc87b36 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12287,6 +12287,8 @@ It has a flexible system of @samp{authorizers} able to manage both
(build-system python-build-system)
(arguments
(list
+ #:tests? (and (not (%current-target-system))
+ (->bool (this-package-native-input "python-pytest")))
#:phases #~(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
@@ -12296,7 +12298,14 @@ It has a flexible system of @samp{authorizers} able to manage both
(propagated-inputs
(list python-appdirs python-pytz python-six))
(native-inputs
- (list python-mock python-parameterized python-pyftpdlib python-pytest))
+ ;; 'python-pyftpdlib' is needed for tests but it indirectly depends Rust,
+ ;; which is currently unavailable on aarch64-linux. Remove all the test
+ ;; dependencies in that case.
+ (if (and (not (%current-target-system))
+ (supported-package? python-pyftpdlib))
+ (list python-mock python-parameterized python-pyftpdlib
+ python-pytest)
+ '()))
(home-page "https://github.com/PyFilesystem/pyfilesystem2/")
(synopsis "File system abstraction layer for Python")
(description "PyFilesystem's @code{FS} object is a file system abstraction