aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-19 14:37:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-19 16:11:53 +0100
commit257ef3f659455ee8763acaba2a5118f128a3dd15 (patch)
tree0349bfda628dfb740285ccbbd21161e2753bc2b6
parent8eccc02ec995f69f3dbe3fe22010503e9ea2aa00 (diff)
downloadguix-257ef3f659455ee8763acaba2a5118f128a3dd15.tar
guix-257ef3f659455ee8763acaba2a5118f128a3dd15.tar.gz
gnu: Add r-mclogit.
* gnu/packages/cran.scm (r-mclogit): New variable.
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e2020ce0e5..617df7c1d7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2592,6 +2592,31 @@ generalized linear, additive and interaction models to potentially
high-dimensional data.")
(license license:gpl2)))
+(define-public r-mclogit
+ (package
+ (name "r-mclogit")
+ (version "0.9.6")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mclogit" version))
+ (sha256
+ (base32
+ "0sbglgak6jhhpx65jnj59hbpvzs8qjsdjc4w02z0m5j9hrnmzp4s"))))
+ (properties `((upstream-name . "mclogit")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-matrix r-memisc))
+ (home-page "https://www.elff.eu/software/mclogit/")
+ (synopsis
+ "Multinomial logit models, with or without random effects or overdispersion")
+ (description
+ "This package provides estimators for multinomial logit models in their
+conditional logit and baseline logit variants, with or without random effects,
+with or without overdispersion. Random effects models are estimated using the
+PQL technique (based on a Laplace approximation) or the MQL technique (based
+on a Solomon-Cox approximation). Estimates should be treated with caution if
+the group sizes are small.")
+ (license license:gpl2)))
+
(define-public r-shadowtext
(package
(name "r-shadowtext")