aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2018-11-26 17:01:58 +0100
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2018-11-26 17:08:34 +0100
commite029d90f45470899d1c37bcbea7fdc5d557e30f7 (patch)
tree9d764ee28e9d8b04b050c85111d97224edaa7f85
parent644af6c87092936e8a556da192ee195db58d65b3 (diff)
downloadguix-e029d90f45470899d1c37bcbea7fdc5d557e30f7.tar
guix-e029d90f45470899d1c37bcbea7fdc5d557e30f7.tar.gz
gnu: ams-lv2: Fix error in configure phase.
Python 3.7 introduced PEP 479. That raised an error in an old waf-script included in the package. An updated waf-script was found in a newer commit that fixes the problem. * gnu/packages/music.scm (ams-lv2)[sources]: Update, using two more commits than version 1.2.1.
-rw-r--r--gnu/packages/music.scm82
1 files changed, 44 insertions, 38 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index fca26edcbb..21659a6429 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2018 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2285,47 +2286,52 @@ follows a traditional multi-track tape recorder control paradigm.")
(license license:gpl2+)))
(define-public ams-lv2
- (package
- (name "ams-lv2")
- (version "1.2.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/blablack/ams-lv2.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1n1dnqnj24xhiy9323lj52nswr5120cj56fpckg802miss05sr6x"))))
- (build-system waf-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-sse-flags
- (lambda* (#:key system #:allow-other-keys)
- (when (not (or (string-prefix? "x86_64" system)
- (string-prefix? "i686" system)))
- (substitute* "wscript"
- (("'-msse', '-mfpmath=sse', ") ""))
- #t))))
- #:tests? #f)) ; no tests
- (inputs
- `(("lv2" ,lv2)
- ("lvtk" ,lvtk)
- ("gtkmm" ,gtkmm-2)
- ("gtk" ,gtk+-2)
- ("cairo" ,cairo)
- ("fftw" ,fftw)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "https://objectivewave.wordpress.com/ams-lv2/")
- (synopsis "Port of Alsa Modular Synth internal modules into LV2")
- (description "This set of LV2 plugins is a port of the internal modules
+ ;; Version 1.2.1 built with Python 3.7 raises an error in the waf-script.
+ ;; Therefore, we take two more commmits than 1.2.1 that introduce an updated
+ ;; waf-script and fix one error.
+ (let ((commit "377d166db54a787b48979171c5652d2eb4f1bbb5")
+ (revision "1"))
+ (package
+ (name "ams-lv2")
+ (version (git-version "1.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/blablack/ams-lv2.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ndgxcxjxwidg7436k0nb5clxkyi878k1j999sbbd1gk2fm0kcqm"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-sse-flags
+ (lambda* (#:key system #:allow-other-keys)
+ (when (not (or (string-prefix? "x86_64" system)
+ (string-prefix? "i686" system)))
+ (substitute* "wscript"
+ (("'-msse', '-mfpmath=sse', ") ""))
+ #t))))
+ #:tests? #f)) ; no tests
+ (inputs
+ `(("lv2" ,lv2)
+ ("lvtk" ,lvtk)
+ ("gtkmm" ,gtkmm-2)
+ ("gtk" ,gtk+-2)
+ ("cairo" ,cairo)
+ ("fftw" ,fftw)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://objectivewave.wordpress.com/ams-lv2/")
+ (synopsis "Port of Alsa Modular Synth internal modules into LV2")
+ (description "This set of LV2 plugins is a port of the internal modules
found in Alsa Modular Synth. These plugins are used to create modular
synthesizers and contain: VCO, VCF, VCA, LFO, slew limiter, envelopes, sample
and hold, etc.")
- (license license:gpl2)))
+ (license license:gpl2))))
(define-public gxtuner
(package