aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2018-11-28 19:48:19 +0000
committerLudovic Courtès <ludo@gnu.org>2018-12-04 10:58:50 +0100
commitaf5236739e2d73132e7ae4678030f0ae4356729c (patch)
treecbe6715d086ba012ee330bcac1a72507ca3785ef
parent7bc5657f8434de06d904c36f8960a1b1dddf10ae (diff)
downloadguix-af5236739e2d73132e7ae4678030f0ae4356729c.tar
guix-af5236739e2d73132e7ae4678030f0ae4356729c.tar.gz
gnu: petsc-openmpi: Configure with support for HYPRE preconditioner.
* gnu/packages/maths.scm (petsc-openmpi)[inputs]: Add hypre-openmpi. [arguments]: Add 'with-hypre=1' flag. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f1b5bb0646..f88cede68a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1767,6 +1767,7 @@ scientific applications modeled by partial differential equations.")
(name "petsc-openmpi")
(inputs
`(("hdf5" ,hdf5-parallel-openmpi)
+ ("hypre" ,hypre-openmpi)
("metis" ,metis)
("mumps" ,mumps-openmpi)
("openmpi" ,openmpi)
@@ -1776,7 +1777,8 @@ scientific applications modeled by partial differential equations.")
(arguments
(substitute-keyword-arguments (package-arguments petsc)
((#:configure-flags cf)
- ``("--with-mpiexec=mpirun"
+ ``("--with-hypre=1"
+ "--with-mpiexec=mpirun"
"--with-metis=1"
"--with-mumps=1"
"--with-scalapack=1"