aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-12-05 14:55:02 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-12-05 14:58:20 +0100
commitaa00797877e972af9ec68194bde23b9e53f56fbb (patch)
treeef47f6d16b0c661fa5d70c78efde081a55486d36
parent3a2627b83cd18ae2a1f60d45cc726e9077b44fbd (diff)
downloadguix-aa00797877e972af9ec68194bde23b9e53f56fbb.tar
guix-aa00797877e972af9ec68194bde23b9e53f56fbb.tar.gz
gnu: beets: Make it compatible with Python 3.7.
* gnu/packages/music.scm (beets)[arguments]<#:phases> [make-python3.7-compatible]: New phase.
-rw-r--r--gnu/packages/music.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b59f258ae5..2314fdc442 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2704,6 +2704,12 @@ Songs can be searched by artist, name or even by a part of the song text.")
(lambda _
(setenv "HOME" (string-append (getcwd) "/tmp"))
#t))
+ (add-after 'unpack 'make-python3.7-compatible
+ (lambda _
+ ;; See <https://github.com/beetbox/beets/issues/2978>.
+ (substitute* "beets/autotag/hooks.py"
+ (("re\\._pattern_type") "re.Pattern"))
+ #t))
(replace 'check
(lambda _
(invoke "nosetests" "-v"))))))