aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-12-01 23:14:59 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-12-05 03:22:55 +0300
commit79a0eabd2a8765c294b3e2decf71a27cd1dd219d (patch)
tree43962a2e5893f14cc3f19b7c3d93f58cbc071034
parent89ca445c298980b7462e6bacff4c044e9e570729 (diff)
downloadguix-79a0eabd2a8765c294b3e2decf71a27cd1dd219d.tar
guix-79a0eabd2a8765c294b3e2decf71a27cd1dd219d.tar.gz
gnu: Add python-xmltodict.
* gnu/packages/xml.scm (python-xmltodict): New variable.
-rw-r--r--gnu/packages/xml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 3ac01133e5..fd4c3fea2c 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -39,6 +39,7 @@
(define-module (gnu packages xml)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages gnupg)
@@ -2152,3 +2153,24 @@ It converts the procedure call into an XML document, sends it to a remote
server using HTTP, and gets back the response as XML. This library provides a
modular implementation of XML-RPC for C and C++.")
(license (list license:psfl license:expat))))
+
+(define-public python-xmltodict
+ (package
+ (name "python-xmltodict")
+ (version "0.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "xmltodict" version))
+ (sha256
+ (base32
+ "1pxh4yjhvmxi1h6f92skv41g4kbsws3ams57150kzn18m907v3cg"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-nose" ,python-nose)))
+ (home-page "https://github.com/martinblech/xmltodict")
+ (synopsis "Work with XML like you are working with JSON")
+ (description "This package provides a Python library to convert XML to
+@code{OrderedDict}.")
+ (license license:expat)))