aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-04 19:44:47 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-04 19:53:04 +0000
commit69a64ecd66733e394a3b116b38f67b354dcebcc9 (patch)
treebaaae430a5cd9f804174bd241a3aec6043f51794
parent30a1f6e21447ddfadf1d8677eb6dddf458d50d50 (diff)
downloadguix-69a64ecd66733e394a3b116b38f67b354dcebcc9.tar
guix-69a64ecd66733e394a3b116b38f67b354dcebcc9.tar.gz
gnu: go-gopkg.in-tomb.v2: Fix build.
Looks like this test isn't compiling with newer versions of go, so fix it to get the package building again. * gnu/packages/golang.scm (go-gopkg.in-tomb.v2)[arguments]: Add new patch-source phase.
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 60890bf724..6c970700a5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -632,7 +632,16 @@ way of specifying command line options.")
"1sv15sri99szkdz1bkh0ir46w9n8prrwx5hfai13nrhkawfyfy10"))))
(build-system go-build-system)
(arguments
- '(#:import-path "gopkg.in/tomb.v2"))
+ '(#:import-path "gopkg.in/tomb.v2"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ ;; Add a missing % to fix the compilation of this test
+ (substitute* "src/gopkg.in/tomb.v2/tomb_test.go"
+ (("t.Fatalf\\(`Killf\\(\"BO%s")
+ "t.Fatalf(`Killf(\"BO%%s"))
+ #t)))))
(synopsis "@code{tomb} handles clean goroutine tracking and termination")
(description
"The @code{tomb} package handles clean goroutine tracking and