aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-12-05 00:10:11 -0500
committerLeo Famulari <leo@famulari.name>2018-12-05 00:12:56 -0500
commit3a2627b83cd18ae2a1f60d45cc726e9077b44fbd (patch)
treee46506edd4ee86a794f7ba620fd2c539e35d695f
parent4b193da3f959244112a85f996d630aa1ed6d0902 (diff)
downloadguix-3a2627b83cd18ae2a1f60d45cc726e9077b44fbd.tar
guix-3a2627b83cd18ae2a1f60d45cc726e9077b44fbd.tar.gz
gnu: khal: Disable another test.
Normally we shouldn't disable tests just because they fail. However, since the recent glibc update, it's not possible to keep using an old khal, because khal requires locales to be set up properly. * gnu/packages/calendar.scm (khal)[arguments]: Disable a failing test.
-rw-r--r--gnu/packages/calendar.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 24e19b472c..a5c677bd4d 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -128,7 +128,9 @@ data units.")
;; running in a TTY:
;; https://github.com/pimutils/khal/issues/683
"not test_printics_read_from_stdin "
- "and not test_import_from_stdin")))))))
+ "and not test_import_from_stdin "
+ ;; https://github.com/pimutils/khal/issues/825
+ "and not test_description_and_location_and_categories")))))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)