aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Eisenmann <eisenmann@fn.de>2018-12-02 11:44:37 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-04 11:06:00 +0100
commit3a1835128db463f7daa190e72ed6e2d3e72675b2 (patch)
tree66372d37d08425fca14882c72b842eb472efdc69
parentdd6cb4a0afc40f6cab79824e792d8aa630a5bd69 (diff)
downloadguix-3a1835128db463f7daa190e72ed6e2d3e72675b2.tar
guix-3a1835128db463f7daa190e72ed6e2d3e72675b2.tar.gz
gnu: enlightenment: Use absolute path to 'edje_cc'.
* gnu/packages/enlightenment.scm (enlightenment)[arguments]: In 'set-system-actions', set absolute file name to 'edje_cc'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/enlightenment.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 43ac388b25..9989e2f5a8 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -275,7 +275,8 @@ Libraries with some extra bells and whistles.")
(let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
(setxkbmap (assoc-ref inputs "setxkbmap"))
(utils (assoc-ref inputs "util-linux"))
- (libc (assoc-ref inputs "libc")))
+ (libc (assoc-ref inputs "libc"))
+ (efl (assoc-ref inputs "efl")))
;; We need to patch the path to 'base.lst' to be able
;; to switch the keyboard layout in E.
(substitute* (list "src/modules/xkbswitch/e_mod_parse.c"
@@ -290,6 +291,9 @@ Libraries with some extra bells and whistles.")
"src/modules/conf_intl/e_int_config_intl.c"
"src/modules/wizard/page_010.c")
(("locale -a") (string-append libc "/bin/locale -a")))
+ (substitute* "src/bin/e_import_config_dialog.c"
+ (("%s/edje_cc -v %s %s %s\", e_prefix_bin_get\\(\\)")
+ (string-append efl "/bin/edje_cc -v %s %s %s\"")))
(substitute* "src/modules/everything/evry_plug_apps.c"
(("/usr/bin/") ""))
(substitute* "configure"