aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-05 07:45:47 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-05 21:21:24 +0000
commit17cfb7aeffaaba70e67e9afb50d7100614ffca7f (patch)
tree22687270020cb81ffff2d45d3b6ad236ace89f20
parent9c5f4b82bb0ed6a0447a68f9cb18c4da5f692acf (diff)
downloadguix-17cfb7aeffaaba70e67e9afb50d7100614ffca7f.tar
guix-17cfb7aeffaaba70e67e9afb50d7100614ffca7f.tar.gz
gnu: ruby-json-pure: Fix build.
The version of test-unit used is greater than one of the gemspec files was specifying. It was already being changed in two places, so this commit changes the json-java.gemspec file as well. * gnu/packages/ruby.scm (ruby-json-pure)[arguments]: Add new fix-json-java.gemspec phase.
-rw-r--r--gnu/packages/ruby.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2fde016851..52832eeeb8 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3010,7 +3010,15 @@ a native C extension.")
(lambda _
;; Regenerate gemspec so loosened dependency constraints are
;; propagated.
- (invoke "rake" "gemspec"))))))
+ (invoke "rake" "gemspec")))
+ (add-after 'regenerate-gemspec 'fix-json-java.gemspec
+ (lambda _
+ ;; This gemspec doesn't look to be generated by the above
+ ;; command, so patch it separately.
+ (substitute* "json-java.gemspec"
+ (("%q<test-unit>\\.freeze, \\[\"~> 2\\.0\"\\]")
+ "%q<test-unit>.freeze, [\">= 2.0\"]"))
+ #t)))))
(native-inputs
`(("bundler" ,bundler)
("ragel" ,ragel)