aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-28 20:30:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-28 20:30:20 +0100
commit5a23696a476298a41cef5a0a0c8860313d027beb (patch)
tree47cff8c2b143c0e02f7e1bff1850b62dfdcd6757
parentad34338d1edba343e04e292b9656363e469fd54b (diff)
downloadguix-5a23696a476298a41cef5a0a0c8860313d027beb.tar
guix-5a23696a476298a41cef5a0a0c8860313d027beb.tar.gz
gnu: fastcap: Fix build and use INVOKE.
* gnu/packages/engineering.scm (fastcap)[native-inputs]: Replace texlive-tiny with a texlive-union including texlive-fonts-amsfonts. [arguments]: Use INVOKE in build phases.
-rw-r--r--gnu/packages/engineering.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 9501e772fd..ea5dd885d1 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -420,7 +420,7 @@ featuring various improvements and bug fixes.")))
;; FIXME: with texlive-tiny citation references are rendered as question
;; marks. During the build warnings like these are printed:
;; LaTeX Warning: Citation `nabors91' on page 2 undefined on input line 3.
- `(("texlive" ,texlive-tiny)
+ `(("texlive" ,(texlive-union (list texlive-fonts-amsfonts)))
("ghostscript" ,ghostscript)))
(arguments
`(#:make-flags '("CC=gcc" "RM=rm" "SHELL=sh" "all")
@@ -432,8 +432,7 @@ featuring various improvements and bug fixes.")))
(modify-phases %standard-phases
(add-after 'build 'make-doc
(lambda _
- (zero? (system* "make" "CC=gcc" "RM=rm" "SHELL=sh"
- "manual"))))
+ (invoke "make" "CC=gcc" "RM=rm" "SHELL=sh" "manual")))
(add-before 'make-doc 'fix-doc
(lambda _
(substitute* "doc/Makefile" (("/bin/rm") (which "rm")))
@@ -474,13 +473,13 @@ featuring various improvements and bug fixes.")))
(setenv "HOME" "/tmp") ; FIXME: for texlive font cache
(with-directory-excursion "doc"
(and
- (every (lambda (file)
- (zero? (system* "dvips" file "-o")))
- (find-files "." "\\.dvi"))
- (every (lambda (file)
- (zero? (system* "ps2pdf" file)))
- '("mtt.ps" "ug.ps" "tcad.ps"))
- (zero? (system* "make" "clean"))))))
+ (for-each (lambda (file)
+ (invoke "dvips" file "-o"))
+ (find-files "." "\\.dvi"))
+ (for-each (lambda (file)
+ (invoke "ps2pdf" file))
+ '("mtt.ps" "ug.ps" "tcad.ps"))
+ (invoke "make" "clean")))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))