aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-27 11:57:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-27 12:48:40 +0200
commit3fcaf42a1cc323e5e0a8cccb4fbbb56d2a9b2753 (patch)
treef6e609c8c31af1e425eaaae9bc9ed45dafc39543
parent474039554de2641966caf5db6aaf6d54c09a5e1b (diff)
downloadguix-3fcaf42a1cc323e5e0a8cccb4fbbb56d2a9b2753.tar
guix-3fcaf42a1cc323e5e0a8cccb4fbbb56d2a9b2753.tar.gz
gnu: python-tornado: Update to 5.1.1.
* gnu/packages/python-web.scm (python-tornado): Update to 5.1.1. [propagated-inputs]: Move python-backports-abc to python2-tornado only. [home-page]: Use https.
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8056c862bd..632de6260e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -665,13 +665,14 @@ teams extension for python-openid.")
(define-public python-tornado
(package
(name "python-tornado")
- (version "4.5.1")
+ (version "5.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tornado" version))
(sha256
- (base32 "1zbkgcdfq81k298awrm8p0xwbwwn2p3nbizdglzfbkskhai082fv"))))
+ (base32
+ "02clqk2116jbnq8lnaqmdw3p52nqrd9ib59r4xz2ll43fpcmhlaf"))))
(build-system python-build-system)
(arguments
'(;; FIXME: Two tests error out with:
@@ -682,14 +683,12 @@ teams extension for python-openid.")
;; (lambda _
;; ;; 'setup.py test' hits an AssertionError on BSD-specific
;; ;; "tornado/platform/kqueue.py". This is the supported method:
- ;; (invoke- "python" "-m" "tornado.test")
+ ;; (invoke "python" "-m" "tornado.test.runtests")
;; #t)))
#:tests? #f))
(native-inputs
`(("python-certifi" ,python-certifi)))
- (propagated-inputs
- `(("python-backports-abc" ,python-backports-abc)))
- (home-page "http://www.tornadoweb.org/")
+ (home-page "https://www.tornadoweb.org/")
(synopsis "Python web framework and asynchronous networking library")
(description
"Tornado is a Python web framework and asynchronous networking library,
@@ -706,6 +705,7 @@ connection to each user.")
(propagated-inputs
`(("python2-backport-ssl-match-hostname"
,python2-backport-ssl-match-hostname)
+ ("python2-backports-abc" ,python2-backports-abc)
("python2-singledispatch" ,python2-singledispatch)
,@(package-propagated-inputs tornado))))))