aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-16 16:48:05 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-16 18:30:57 +0100
commitfb8a77f456725ed6250bb57f58197f9954f30e57 (patch)
tree7c5209fd2e6aeae6952f41fc50c9a1d56edd1499
parent4f4086848bd6c2eb2c85ede3822778a116d1ce71 (diff)
downloadguix-fb8a77f456725ed6250bb57f58197f9954f30e57.tar
guix-fb8a77f456725ed6250bb57f58197f9954f30e57.tar.gz
gnu: guile-syntax-highlight: Add "guile3.0-syntax-highlight" variant.
* gnu/packages/guile-xyz.scm (guile-syntax-highlight)[source]: Add 'snippet' and 'modules'. (guile3.0-syntax-highlight): New field.
-rw-r--r--gnu/packages/guile-xyz.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index cf6325340f..9edb718faa 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -544,7 +544,15 @@ is not available for Guile 2.0.")
version ".tar.gz"))
(sha256
(base32
- "1p771kq15x83483m23bhah1sz6vkalg3drm7x279f4j1cxligkzi"))))
+ "1p771kq15x83483m23bhah1sz6vkalg3drm7x279f4j1cxligkzi"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Allow builds with Guile 3.0.
+ (substitute* "configure"
+ (("2\\.2 2\\.0")
+ "3.0 2.2 2.0"))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -558,6 +566,12 @@ HTML (via SXML) or any other format for rendering.")
(home-page "http://dthompson.us/projects/guile-syntax-highlight.html")
(license license:lgpl3+)))
+(define-public guile3.0-syntax-highlight
+ (package
+ (inherit guile-syntax-highlight)
+ (name "guile3.0-syntax-highlight")
+ (inputs `(("guile" ,guile-3.0)))))
+
(define-public guile-sjson
(package
(name "guile-sjson")