aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-12-23 17:29:03 -0500
committerLeo Famulari <leo@famulari.name>2020-12-23 17:55:16 -0500
commite8d4c6deaac8f2d81f63b092b6496f0c235c9389 (patch)
treeddbfdb61518bb0a6475890810fdfa25ba3399c48
parent119fd58922b00d43d4f8b055f3f622478a13f46d (diff)
downloadguix-e8d4c6deaac8f2d81f63b092b6496f0c235c9389.tar
guix-e8d4c6deaac8f2d81f63b092b6496f0c235c9389.tar.gz
gnu: VLC: Fix build with Qt 5.15.
* gnu/packages/patches/vlc-qt-5.15.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/video.scm (vlc)[source]: Use it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/vlc-qt-5.15.patch56
-rw-r--r--gnu/packages/video.scm1
3 files changed, 58 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4f8bd8de69..89e97e0ffe 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1699,6 +1699,7 @@ dist_patch_DATA = \
%D%/packages/patches/vboot-utils-fix-tests-show-contents.patch \
%D%/packages/patches/vboot-utils-skip-test-workbuf.patch \
%D%/packages/patches/vcflib-use-shared-libraries.patch \
+ %D%/packages/patches/vlc-qt-5.15.patch \
%D%/packages/patches/vigra-python-compat.patch \
%D%/packages/patches/vinagre-newer-freerdp.patch \
%D%/packages/patches/vinagre-newer-rdp-parameters.patch \
diff --git a/gnu/packages/patches/vlc-qt-5.15.patch b/gnu/packages/patches/vlc-qt-5.15.patch
new file mode 100644
index 0000000000..e986a99861
--- /dev/null
+++ b/gnu/packages/patches/vlc-qt-5.15.patch
@@ -0,0 +1,56 @@
+Fix build of VLC with Qt 5.15. Otherwise it fails like this:
+
+------
+In file included from gui/qt/util/timetooltip.moc.cpp:10:0:
+gui/qt/util/timetooltip.hpp:49:18: error: field ‘mPainterPath’ has incomplete type ‘QPainterPath’
+ QPainterPath mPainterPath;
+ ^~~~~~~~~~~~
+In file included from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtGui/qbrush.h:49:0,
+ from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtGui/qpalette.h:46,
+ from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtWidgets/qwidget.h:48,
+ from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtWidgets/QWidget:1,
+ from gui/qt/util/timetooltip.hpp:27,
+ from gui/qt/util/timetooltip.moc.cpp:10:
+/gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
+ class QPainterPath;
+ ^~~~~~~~~~~~
+make[4]: *** [Makefile:25852: gui/qt/util/libqt_plugin_la-timetooltip.moc.lo] Error 1
+------
+
+diff --git a/modules/gui/qt/components/playlist/views.cpp b/modules/gui/qt/components/playlist/views.cpp
+index 24db9d9..73c1779 100644
+--- a/modules/gui/qt/components/playlist/views.cpp
++++ b/modules/gui/qt/components/playlist/views.cpp
+@@ -27,6 +27,7 @@
+ #include "input_manager.hpp" /* THEMIM */
+
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QRect>
+ #include <QStyleOptionViewItem>
+ #include <QFontMetrics>
+diff --git a/modules/gui/qt/dialogs/plugins.cpp b/modules/gui/qt/dialogs/plugins.cpp
+index d233382..69728eb 100644
+--- a/modules/gui/qt/dialogs/plugins.cpp
++++ b/modules/gui/qt/dialogs/plugins.cpp
+@@ -53,6 +53,7 @@
+ #include <QListView>
+ #include <QListWidget>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QStyleOptionViewItem>
+ #include <QKeyEvent>
+ #include <QPushButton>
+diff --git a/modules/gui/qt/util/timetooltip.hpp b/modules/gui/qt/util/timetooltip.hpp
+index 6a1329e..9f50b18 100644
+--- a/modules/gui/qt/util/timetooltip.hpp
++++ b/modules/gui/qt/util/timetooltip.hpp
+@@ -25,6 +25,7 @@
+ #include "qt.hpp"
+
+ #include <QWidget>
++#include <QPainterPath>
+
+ class TimeTooltip : public QWidget
+ {
+
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0740abe040..2813bf0570 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1772,6 +1772,7 @@ videoformats depend on the configuration flags of ffmpeg.")
"https://download.videolan.org/pub/videolan/vlc/"
(car (string-split version #\-))
"/vlc-" version ".tar.xz"))
+ (patches (search-patches "vlc-qt-5.15.patch"))
(sha256
(base32
"1f46h0hv7fk35zg4iczlp7ib7h2jmh8m4r5klw3g2558ib9134qq"))))