aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-20 16:06:49 +0100
committerMarius Bakke <marius@gnu.org>2020-12-20 16:06:49 +0100
commite693617f559f49d1d2606dd5ad997e444b9ad1b5 (patch)
treef8775a9761e083d36b125d8df73c22033778276d
parent9128ca0475ed243994f9be0abbdf5cabe839808c (diff)
downloadguix-e693617f559f49d1d2606dd5ad997e444b9ad1b5.tar
guix-e693617f559f49d1d2606dd5ad997e444b9ad1b5.tar.gz
gnu: PostgreSQL: Do not embed references to build tools.
Fixes <https://bugs.gnu.org/25527>. * gnu/packages/databases.scm (postgresql-13)[arguments]: In #:configure-flags, provide non-absolute references to the build tools.
-rw-r--r--gnu/packages/databases.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 8c0da1b666..733c8c4ef5 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1187,7 +1187,12 @@ developed in C/C++ to MariaDB and MySQL databases.")
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl")
+ `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl"
+ ;; PostgreSQL installs its own Makefile (should it?).
+ ;; Prevent it from retaining needless references to
+ ;; the build tools in order to save size.
+ "MKDIR_P=mkdir -p" "INSTALL_BIN=install -c"
+ "LD=ld" "TAR=tar")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-/bin/sh