aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-01-04 20:23:40 -0500
committerLeo Famulari <leo@famulari.name>2021-01-04 20:27:22 -0500
commitb3ec77723d5d1c75155da635b277b54e29c68b23 (patch)
tree275a4e4f07980f984ae19996edd3f96c00f6166e
parent48d8d92c51f64256bba2bdbb2a1027a5fab71a3d (diff)
downloadguix-b3ec77723d5d1c75155da635b277b54e29c68b23.tar
guix-b3ec77723d5d1c75155da635b277b54e29c68b23.tar.gz
gnu: python-pyopenssl: Skip a test that assumes a 64-bit system.
* gnu/packages/python-crypto.scm (python-pyopenssl)[arguments]: Skip another test in the 'check' phase.
-rw-r--r--gnu/packages/python-crypto.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index ce22cc0dfc..96801e97d2 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -596,7 +596,10 @@ message digests and key derivation functions.")
"not test_fallback_default_verify_paths "
;; This test attempts to make a connection to
;; an external web service.
- "and not test_set_default_verify_paths")))))))
+ "and not test_set_default_verify_paths "
+ ;; Fails on i686-linux and possibly other 32-bit platforms
+ ;; https://github.com/pyca/pyopenssl/issues/974
+ "and not test_verify_with_time")))))))
(propagated-inputs
`(("python-cryptography" ,python-cryptography)
("python-six" ,python-six)))