aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-13 21:13:03 +0100
committerMarius Bakke <marius@gnu.org>2020-12-13 21:44:12 +0100
commita73302ec91855fa1913a2702daee25f8b9cf487b (patch)
treecf77d651ff6c6fbd3ae6e1dc241144fe625c2992
parent4b4c93d63937a764482e2bba83358d7bee65034c (diff)
downloadguix-a73302ec91855fa1913a2702daee25f8b9cf487b.tar
guix-a73302ec91855fa1913a2702daee25f8b9cf487b.tar.gz
gnu: postgresql: Make version 13 the default.
While at it, rearrange so that variables are in order, and also inherit the patches in lower versions, as the disable-resolve_symlinks patch was missing in 11 and 9. * gnu/packages/databases.scm (postgresql-13): Swap places with ... (postgresql): ... this. Turn into dummy pointer variable and move it last. (postgresql-11): Inherit from POSTGRESQL-13. Also inherit source. (postgresql-10): Inherit from POSTGRESQL-11. (postgresql-9.6): Inherit from POSTGRESQL-10. Also inherit source.
-rw-r--r--gnu/packages/databases.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index bf9f31ad25..8c0da1b666 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1173,17 +1173,17 @@ developed in C/C++ to MariaDB and MySQL databases.")
(license license:lgpl2.1+)))
;; Don't forget to update the other postgresql packages when upgrading this one.
-(define-public postgresql
+(define-public postgresql-13
(package
(name "postgresql")
- (version "10.13")
+ (version "13.1")
(source (origin
(method url-fetch)
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
- "1qal0yp7a90yzya7hl56gsmw5fvacplrdhpn7h9gnbyr1i2iyw2d"))
+ "07z6zwr58dckaa97yl9ml240z83d1lhgaxw9aq49i8lsp21mqd0j"))
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
(build-system gnu-build-system)
(arguments
@@ -1219,46 +1219,45 @@ TIMESTAMP. It also supports storage of binary large objects, including
pictures, sounds, or video.")
(license (license:x11-style "file://COPYRIGHT"))))
-(define-public postgresql-10 postgresql)
-
-(define-public postgresql-13
+(define-public postgresql-11
(package
- (inherit postgresql)
- (version "13.1")
+ (inherit postgresql-13)
+ (name "postgresql")
+ (version "11.6")
(source (origin
- (inherit (package-source postgresql))
+ (inherit (package-source postgresql-13))
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
- "07z6zwr58dckaa97yl9ml240z83d1lhgaxw9aq49i8lsp21mqd0j"))))))
+ "0w1iq488kpzfgfnlw4k32lz5by695mpnkq461jrgsr99z5zlz4j9"))))))
-(define-public postgresql-11
+(define-public postgresql-10
(package
- (inherit postgresql)
- (name "postgresql")
- (version "11.6")
+ (inherit postgresql-11)
+ (version "10.13")
(source (origin
- (method url-fetch)
+ (inherit (package-source postgresql-11))
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
- "0w1iq488kpzfgfnlw4k32lz5by695mpnkq461jrgsr99z5zlz4j9"))))))
+ "1qal0yp7a90yzya7hl56gsmw5fvacplrdhpn7h9gnbyr1i2iyw2d"))))))
(define-public postgresql-9.6
(package
- (inherit postgresql)
- (name "postgresql")
+ (inherit postgresql-10)
(version "9.6.16")
(source (origin
- (method url-fetch)
+ (inherit (package-source postgresql-10))
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
"1rr2dgv4ams8r2lp13w85c77rkmzpb88fjlc28mvlw6zq2fblv2w"))))))
+(define-public postgresql postgresql-13)
+
(define-public python-pymysql
(package
(name "python-pymysql")