aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-12-29 16:18:07 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-12-29 16:42:26 +0200
commit9680144d4d6d728b832eb73ff9d66c093d29ef06 (patch)
tree55a4b521b3d5f6adefde13536347a8d4d0c3605d
parentfc0c95bca640dc83321cfec38805356e565ba2da (diff)
downloadguix-9680144d4d6d728b832eb73ff9d66c093d29ef06.tar
guix-9680144d4d6d728b832eb73ff9d66c093d29ef06.tar.gz
gnu: purpose: Fix build.
* gnu/packages/kde-frameworks.scm (purpose)[arguments]: Add phase to force use of pre-Qt-5.15 logic.
-rw-r--r--gnu/packages/kde-frameworks.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 012731572b..5482400f02 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016-2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -3476,6 +3476,13 @@ script engines.")
("qtdeclarative" ,qtdeclarative)))
(arguments
`(#:tests? #f ;; seem to require network; don't find QTQuick components
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'dont-use-qt515-logic
+ (lambda _
+ (substitute* "src/externalprocess/purposeprocess_main.cpp"
+ ((" 15") " 16"))
+ #t)))
#:configure-flags '("-DBUILD_TESTING=OFF"))) ; not run anyway
(home-page "https://community.kde.org/Frameworks")
(synopsis "Offers available actions for a specific purpose")