aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-01-18 14:39:13 -0500
committerLeo Famulari <leo@famulari.name>2021-01-18 15:07:05 -0500
commit8b55544212a90b0276df49596a3d373e5c2e8f5c (patch)
tree448547fc0d0be08973edc898d4c5d101bc2b2d03
parent6985a1acb3e9cc4cad8b6f63d77154842d25c929 (diff)
downloadguix-8b55544212a90b0276df49596a3d373e5c2e8f5c.tar
guix-8b55544212a90b0276df49596a3d373e5c2e8f5c.tar.gz
gnu: mesa: Skip another test.
* gnu/packages/patches/mesa-skip-disk-cache-test.patch: Rename to ... * gnu/packages/patches/mesa-skip-tests.patch: ... new file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gl.scm (mesa)[source]: Adjust accordingly.
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/gl.scm2
-rw-r--r--gnu/packages/patches/mesa-skip-disk-cache-test.patch19
-rw-r--r--gnu/packages/patches/mesa-skip-tests.patch49
4 files changed, 51 insertions, 21 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 479277aafa..ba95aeca64 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1348,7 +1348,7 @@ dist_patch_DATA = \
%D%/packages/patches/libmemcached-build-with-gcc7.patch \
%D%/packages/patches/libmhash-hmac-fix-uaf.patch \
%D%/packages/patches/mediastreamer2-srtp2.patch \
- %D%/packages/patches/mesa-skip-disk-cache-test.patch \
+ %D%/packages/patches/mesa-skip-tests.patch \
%D%/packages/patches/mescc-tools-boot.patch \
%D%/packages/patches/meson-for-build-rpath.patch \
%D%/packages/patches/metabat-fix-compilation.patch \
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index dc64ccf85e..2612347913 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -249,7 +249,7 @@ also known as DXTn or DXTC) for Mesa.")
(base32
"14m09bk7akj0k02lg8fhvvzbdsashlbdsgl2cw7wbqfj2mhdqwh5"))
(patches
- (search-patches "mesa-skip-disk-cache-test.patch"))))
+ (search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
(propagated-inputs
`(;; The following are in the Requires.private field of gl.pc.
diff --git a/gnu/packages/patches/mesa-skip-disk-cache-test.patch b/gnu/packages/patches/mesa-skip-disk-cache-test.patch
deleted file mode 100644
index 190f6b6ee1..0000000000
--- a/gnu/packages/patches/mesa-skip-disk-cache-test.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-disk_cache_create() here looks up the users home directory from <pwd.h>
-which resolves to "/" in the build environment. I could not find an easy
-way to set the home directory to something else, so we disable this test
-for now.
-
---- a/src/compiler/glsl/tests/cache_test.c
-+++ b/src/compiler/glsl/tests/cache_test.c
-@@ -170,11 +170,6 @@
- unsetenv("MESA_GLSL_CACHE_DIR");
- unsetenv("XDG_CACHE_HOME");
-
-- cache = disk_cache_create("test", "make_check", 0);
-- expect_non_null(cache, "disk_cache_create with no environment variables");
--
-- disk_cache_destroy(cache);
--
- /* Test with XDG_CACHE_HOME set */
- setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
- cache = disk_cache_create("test", "make_check", 0);
diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
new file mode 100644
index 0000000000..2622d5d312
--- /dev/null
+++ b/gnu/packages/patches/mesa-skip-tests.patch
@@ -0,0 +1,49 @@
+disk_cache_create() here looks up the users home directory from <pwd.h>
+which resolves to "/" in the build environment. I could not find an easy
+way to set the home directory to something else, so we disable this test
+for now.
+
+--- a/src/compiler/glsl/tests/cache_test.c
++++ b/src/compiler/glsl/tests/cache_test.c
+@@ -170,11 +170,6 @@
+ unsetenv("MESA_GLSL_CACHE_DIR");
+ unsetenv("XDG_CACHE_HOME");
+
+- cache = disk_cache_create("test", "make_check", 0);
+- expect_non_null(cache, "disk_cache_create with no environment variables");
+-
+- disk_cache_destroy(cache);
+-
+ /* Test with XDG_CACHE_HOME set */
+ setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
+ cache = disk_cache_create("test", "make_check", 0);
+
+This test fails on i686-linux. I couldn't come up with a regex that
+could be used to disable it just on i686-linux, so we disable it
+completely with this patch:
+
+https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
+
+diff --git a/src/util/meson.build b/src/util/meson.build
+index 0893f64..909b3e0 100644
+--- a/src/util/meson.build
++++ b/src/util/meson.build
+@@ -289,18 +289,6 @@ if with_tests
+ suite : ['util'],
+ )
+
+- test(
+- 'u_debug_stack',
+- executable(
+- 'u_debug_stack_test',
+- files('u_debug_stack_test.cpp'),
+- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+- dependencies : [idep_mesautil, idep_gtest],
+- c_args : [c_msvc_compat_args],
+- ),
+- suite : ['util'],
+- )
+-
+ process_test_exe = executable(
+ 'process_test',
+ files('process_test.c'),