aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-02-01 20:14:31 +0000
committerChristopher Baines <mail@cbaines.net>2021-02-01 20:14:31 +0000
commit673b5b794f37959f63da5ff3c52c2f9849316a15 (patch)
tree6e288bdb46aec6fd947b4f681738f0cdbc767875
parent75b775e81b5a81a59656eeba8811b42f45d503da (diff)
downloadguix-673b5b794f37959f63da5ff3c52c2f9849316a15.tar
guix-673b5b794f37959f63da5ff3c52c2f9849316a15.tar.gz
gnu: python-xlib: Update to 0.29.
Make python-six a propagated input as it's used at runtime. * gnu/packages/python-xyz.scm (python-xlib): Update to 0.29. [native-inputs]: Move python-six to… [propagated-inputs]: …here.
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5199ac4d11..5ee4120666 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8014,7 +8014,7 @@ falling into the Python interpreter.")
(define-public python-xlib
(package
(name "python-xlib")
- (version "0.27")
+ (version "0.29")
(source
(origin
(method git-fetch)
@@ -8023,7 +8023,7 @@ falling into the Python interpreter.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "09kimic8rhprx3q8nzalc4aggg42ahqm4v5qcj8dm68yvxfdk986"))))
+ (base32 "17cwd2knqm2vwrii3kqii9abwsnydhpg4byqx1vy7rjs6i1vbqfc"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -8039,8 +8039,9 @@ falling into the Python interpreter.")
(native-inputs
`(("python-mock" ,python-mock)
("python-setuptools-scm" ,python-setuptools-scm)
- ("python-six" ,python-six)
("xorg-server" ,xorg-server)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
(home-page "https://github.com/python-xlib/python-xlib")
(synopsis "Python X11 client library")
(description