aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-26 10:23:04 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-26 10:33:11 +0200
commit4f8d5e63b2f83fc0b9297e874f03c8424303b488 (patch)
tree5e4e282b8695c35c6c4e2c2446ddbe0255323fc6
parentda4483f3790a70058caeb7d208651b18d560ad60 (diff)
downloadguix-4f8d5e63b2f83fc0b9297e874f03c8424303b488.tar
guix-4f8d5e63b2f83fc0b9297e874f03c8424303b488.tar.gz
gnu: shadow: Build without pam for the Hurd.
* gnu/packages/admin.scm (shadow)[arguments]: Adjust configure-flags to not use pam when building for the Hurd. [inputs]: Only use linux-pam when not building for the Hurd.
-rw-r--r--gnu/packages/admin.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 87b0f36cc1..e14b84f769 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -676,7 +676,10 @@ hostname.")
`(;; Assume System V `setpgrp (void)', which is the default on GNU
;; variants (`AC_FUNC_SETPGRP' is not cross-compilation capable.)
#:configure-flags
- '("--with-libpam" "ac_cv_func_setpgrp_void=yes")
+ '(,@(if (hurd-target?)
+ '()
+ '("--with-libpam"))
+ "ac_cv_func_setpgrp_void=yes")
#:phases
(modify-phases %standard-phases
@@ -701,7 +704,10 @@ hostname.")
(for-each delete-file (find-files man "^groups\\."))
#t))))))
- (inputs `(("linux-pam" ,linux-pam)))
+ (inputs
+ `(,@(if (hurd-target?)
+ '()
+ `(("linux-pam" ,linux-pam)))))
(home-page "https://github.com/shadow-maint/shadow")
(synopsis "Authentication-related tools such as passwd, su, and login")
(description