aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-13 20:55:05 +0100
committerMarius Bakke <marius@gnu.org>2020-12-13 21:44:12 +0100
commit4b4c93d63937a764482e2bba83358d7bee65034c (patch)
tree44c3e96a2604adef111cb7c3e93e467f1b117a37
parent861188a0a87c681dfb4fb9af4a0c4d11bff204c0 (diff)
downloadguix-4b4c93d63937a764482e2bba83358d7bee65034c.tar
guix-4b4c93d63937a764482e2bba83358d7bee65034c.tar.gz
gnu: mesa: Build with LLVM 11.
* gnu/packages/gl.scm (mesa)[inputs]: Change from LLVM-10 to LLVM-11. (mesa-opencl)[native-inputs]: Change from CLANG-10 to CLANG-11.
-rw-r--r--gnu/packages/gl.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 966459fb51..dc64ccf85e 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -272,7 +272,7 @@ also known as DXTn or DXTC) for Mesa.")
,@(match (%current-system)
((or "x86_64-linux" "i686-linux")
;; Note: update the 'clang' input of mesa-opencl when bumping this.
- `(("llvm" ,llvm-10)))
+ `(("llvm" ,llvm-11)))
(_
`()))
("wayland" ,wayland)
@@ -452,7 +452,7 @@ from software emulation to complete hardware acceleration for modern GPUs.")
`(("libclc" ,libclc)
,@(package-inputs mesa)))
(native-inputs
- `(("clang" ,clang-10)
+ `(("clang" ,clang-11)
,@(package-native-inputs mesa)))))
(define-public mesa-opencl-icd