aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-13 01:04:41 +0100
committerMarius Bakke <marius@gnu.org>2020-12-13 21:44:12 +0100
commit17c6b81a67aca90ea13fce2d2a1695a9b5d3be3b (patch)
treea3a9cb4a0942d76fcd5681c7c8d4696ee8b5cbca
parent6dfa6ddc21c0235be99499353d1f41fa50cc27ea (diff)
downloadguix-17c6b81a67aca90ea13fce2d2a1695a9b5d3be3b.tar
guix-17c6b81a67aca90ea13fce2d2a1695a9b5d3be3b.tar.gz
gnu: elfutils: Update to 0.182.
* gnu/packages/elf.scm (elfutils): Update to 0.182. [arguments]: Add "--disable-libdebuginfod" and "--disable-debuginfod" to #:configure-flags.
-rw-r--r--gnu/packages/elf.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 48558d5f14..e5ce481fa8 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Mark Wielaard <mark@klomp.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
@@ -46,14 +46,14 @@
(define-public elfutils
(package
(name "elfutils")
- (version "0.176")
+ (version "0.182")
(source (origin
(method url-fetch)
(uri (string-append "https://sourceware.org/elfutils/ftp/"
version "/elfutils-" version ".tar.bz2"))
(sha256
(base32
- "08qhrl4g6qqr4ga46jhh78y56a47p3msa5b2x1qhzbxhf71lfmzb"))
+ "0n48dcadjy0wiilddzav2zaxdi30qkkfp160gw5mycyz9s8hdi7c"))
(patches (search-patches "elfutils-tests-ptrace.patch"))))
(build-system gnu-build-system)
@@ -68,7 +68,16 @@
;; know where to find each other.
`(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
- "/lib"))
+ "/lib")
+ ;; TODO: Enable the debuginfo server. It
+ ;; increases the closure size significantly
+ ;; and presents bootstrapping problems, so
+ ;; we disable it for now. See
+ ;; https://issues.guix.gnu.org/38803 and
+ ;; https://sourceware.org/bugzilla/show_bug.cgi?id=25509
+ ;; for more information.
+ "--disable-libdebuginfod"
+ "--disable-debuginfod")
;; Disable tests on MIPS and PowerPC (without changing
;; the arguments list on other systems).