aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-20 19:07:55 +0100
committerMarius Bakke <marius@gnu.org>2020-12-20 19:09:22 +0100
commit034cfbd2449387c15823cd9ec3e91661f9e5bf49 (patch)
tree098afe6dc0a540a42c49896eb69a4b2bedfedcc0
parenta210c0d13752c38a850746fd97948121046a0e58 (diff)
downloadguix-034cfbd2449387c15823cd9ec3e91661f9e5bf49.tar
guix-034cfbd2449387c15823cd9ec3e91661f9e5bf49.tar.gz
gnu: glib: Increase test timeout on armhf-linux.
* gnu/packages/glib.scm (glib)[arguments]: Add phase to adjust test timeouts to account for slower systems.
-rw-r--r--gnu/packages/glib.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a37369c49a..3fe440515d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -227,6 +227,17 @@ shared NFS home directories.")
(("gio-launch-desktop")
(string-append out "/libexec/gio-launch-desktop")))
#t)))
+ ;; TODO: Remove the conditional in the next core-updates cycle.
+ ;; Needed to build glib on slower ARM nodes.
+ ,@(if (string-prefix? "arm" (%current-system))
+ `((add-after 'unpack 'increase-test-timeout
+ (lambda _
+ (substitute* "meson.build"
+ (("test_timeout = 60")
+ "test_timeout = 90")
+ (("test_timeout_slow = 120")
+ "test_timeout_slow = 180")))))
+ '())
(add-before 'build 'pre-build
(lambda* (#:key inputs outputs #:allow-other-keys)
;; For tests/gdatetime.c.