aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-10 19:13:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-10 20:09:56 +0200
commitff0efc8f6c35606878ca009f3582f5257db2c9e3 (patch)
tree9f95603ff7947c404a17811f46ef83d2d30723e4
parentef42bc3e56b159b36207303dd5b54b6c52574c40 (diff)
downloadguix-ff0efc8f6c35606878ca009f3582f5257db2c9e3.tar
guix-ff0efc8f6c35606878ca009f3582f5257db2c9e3.tar.gz
gnu: python-bleach: Update to 3.1.0.
* gnu/packages/check.scm (python-pytest-runner-2, python2-pytest-runner-2): New public variables. * gnu/packages/python-xyz.scm (python-bleach): Update to 3.1.0. [propagated-inputs]: Remove PYTHON-HTML5LIB-0.9. Add PYTHON-WEBENCODINGS. [native-inputs]: Remove PYTHON-NOSE. Add PYTHON-PYTEST and PYTHON-PYTEST-RUNNER-2.
-rw-r--r--gnu/packages/check.scm16
-rw-r--r--gnu/packages/python-xyz.scm9
2 files changed, 21 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index dab0bd39c3..c7d8615b0b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -816,6 +816,22 @@ supports coverage of subprocesses.")
(define-public python2-pytest-runner
(package-with-python2 python-pytest-runner))
+;; python-bleach 3.1.0 requires this ancient version of pytest-runner.
+;; Remove once no longer needed.
+(define-public python-pytest-runner-2
+ (package/inherit
+ python-pytest-runner
+ (version "2.12.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-runner" version))
+ (sha256
+ (base32
+ "11ivjj9hfphkv4yfb2g74av4yy86y8gcbf7gbif0p1hcdfnxg3w6"))))))
+
+(define-public python2-pytest-runner-2
+ (package-with-python2 python-pytest-runner-2))
+
(define-public python-pytest-mock
(package
(name "python-pytest-mock")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 10fe5ee553..b6a50de503 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7742,20 +7742,21 @@ Jupyter Notebook format and Python APIs for working with notebooks.")
(define-public python-bleach
(package
(name "python-bleach")
- (version "1.4.3")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "bleach" version))
(sha256
(base32
- "0jvg3jxrvnx7xmm9gj262v60ib452xlnwlb0navyp7jsvcd0d4qj"))))
+ "1yhrgrhkln8bd6gn3imj69g1h4xqah9gaz9q26crqr6gmmvpzprz"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-html5lib" ,python-html5lib-0.9)
+ `(("python-webencodings" ,python-webencodings)
("python-six" ,python-six)))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner-2)))
(home-page "https://github.com/jsocol/bleach")
(synopsis "Whitelist-based HTML-sanitizing tool")
(description "Bleach is an easy whitelist-based HTML-sanitizing tool.")