aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-10-08 14:38:32 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-10-08 23:07:27 +0200
commitf875d76f16203e6ad235ec2c03ac784852ac1a20 (patch)
tree0d4e71b18efa44a3a87e0f467cbcc22c032f1e03
parentd28c113f6b024547bf7dc7d56d8643718280a7dd (diff)
downloadguix-f875d76f16203e6ad235ec2c03ac784852ac1a20.tar
guix-f875d76f16203e6ad235ec2c03ac784852ac1a20.tar.gz
gnu: python2-tqdm: Depend on python2-functools32.
* gnu/packages/python-xyz.scm (python-tqdm)[properties]: Add python2-variant. (python2-tqdm): Use 'strip-python2-variant'. [native-inputs]: Add python2-functools32. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b0f5ec7588..c30532266c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13746,10 +13746,15 @@ ignoring formatting changes.")
"Make loops show a progress bar on the console by just wrapping any
iterable with @code{|tqdm(iterable)|}. Offers many options to define
design and layout.")
- (license (list license:mpl2.0 license:expat))))
+ (license (list license:mpl2.0 license:expat))
+ (properties `((python2-variant . ,(delay python2-tqdm))))))
(define-public python2-tqdm
- (package-with-python2 python-tqdm))
+ (let ((tqdm (package-with-python2
+ (strip-python2-variant python-tqdm))))
+ (package (inherit tqdm)
+ (native-inputs `(("python2-functools32" ,python2-functools32)
+ ,@(package-native-inputs tqdm))))))
(define-public python-pkginfo
(package